已存在的程序types:com.google.android.gms.internal.zzfq

我收到这个错误。 尽管尝试了所有的事情我无法解决它。 请帮帮我。

我尝试过的事情是:

  1. 删除.build.idea等然后重建
  2. 清洁和重建
  3. 更改编译库的版本

谢谢

插件

 apply plugin: 'com.android.application' apply plugin: 'kotlin-android' apply plugin: 'kotlin-android-extensions' apply plugin: 'io.fabric' 

Android的

 android { dexOptions { preDexLibraries = false javaMaxHeapSize "2g" } compileSdkVersion 27 buildToolsVersion '27.0.3' defaultConfig { applicationId "com.funzone.alarmnap" minSdkVersion 16 targetSdkVersion 27 versionCode 1 multiDexEnabled true versionName "1.1" vectorDrawables.useSupportLibrary = true testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner" } buildTypes { release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } } 

Greendao插件

  apply plugin: 'org.greenrobot.greendao' greendao { targetGenDir 'src/main/java' schemaVersion 2 } 

所有图书馆:

 dependencies { implementation fileTree(include: ['*.jar'], dir: 'libs') implementation 'com.jjoe64:graphview:4.2.1' implementation "org.jetbrains.kotlin:kotlin-stdlib-jre7:$kotlin_version" implementation 'com.android.support:appcompat-v7:27.1.0' implementation 'com.facebook.android:audience-network-sdk:4.+' implementation 'com.facebook.android:facebook-android-sdk:[4,5)' implementation 'com.facebook.android:notifications:1.0.2' implementation 'com.android.support.constraint:constraint-layout:1.0.2' implementation 'com.android.support:design:27.1.0' implementation 'com.android.support:support-v4:27.1.0' implementation 'com.android.support:support-v13:27.1.0' implementation 'com.android.support:cardview-v7:27.1.0' implementation 'com.google.firebase:firebase-messaging:12.0.1' implementation 'com.google.firebase:firebase-core:12.0.1' implementation 'com.crashlytics.sdk.android:crashlytics:2.9.1' implementation 'com.android.support:multidex:1.0.3' implementation 'org.greenrobot:greendao:3.2.2' testImplementation 'junit:junit:4.12' testImplementation "org.robolectric:shadows-multidex:3.0" testImplementation 'org.robolectric:robolectric:3.4.2' implementation 'com.android.support:preference-v7:27.1.0' } repositories { mavenCentral() google() } 

谷歌插件

 apply plugin: 'com.google.gms.google-services' 

我在我的项目中解决了同样的问题 – 将Kotlin插件更新为1.2.41后(我不知道它是否真的相关。 编辑:显然这与Kotlin无关) – 用:

 classpath 'com.google.gms:google-services:3.2.1' 

https://developers.google.com/android/guides/google-services-plugin

备注:我可以使用独特的15.0.0 Google Play Services库版本,但不能使用play-services-tagmanagerplay-services-tagmanager

 implementation "com.google.android.gms:play-services-tagmanager:15.0.2" implementation "com.google.firebase:firebase-core:15.0.2" 

该项目正在编制中。

  1. 如果您在应用程序的gradle级别使用firebase,请设置实现’com.google.firebase:firebase-messaging:15.0.2′
  2. 在项目gradle级别设置classpath“com.google.gms:google-services:3.2.0”

同步gradle文件

  classpath 'com.google.gms:google-services:3.2.0' 

 //Firebase implementation 'com.google.firebase:firebase-core:15.0.2' implementation 'com.google.firebase:firebase-messaging:15.0.2' implementation 'com.google.firebase:firebase-auth:15.0.0' implementation 'com.google.firebase:firebase-database:15.0.1' 

我升级到kotlin插件版本后开始看到这个:1.2.41-release-Studio3.1-1。

从15.0.0 – > 15.0.2升级firebase-core和firebase-messaging。 修复了问题,数据库,auth和gms-auth-services的版本为15.0.0

我使用新的firebase独立版本号修复了此问题https://firebase.google.com/support/release-notes/android#latest_sdk_versions

SDK更新 – 2018年5月2日 – > Firebase Android SDK现在具有独立的版本号,允许更频繁,灵活的更新。

在此处输入图像描述

您需要更新各个库的版本。 这解决了Google Services Gradle插件版本3.3.0报告的问题: com.google.android.gms:play-services-measurement-base正在[[15.0.0,15.0]的各种其他库请求。 0],[15.0.2,15.0.2]],但解析为15.0.2 ……

在此处输入图像描述

有关最新更新检查发布更新的更多信息,请参阅以下链接Firebase May 2nd发行说明

我有同样的错误,我修复了以下更新行:

build.grade(Project:[project_name])

 classpath 'com.google.gms:google-services:3.3.0' 

build.grade(模块:app)

 implementation 'com.firebaseui:firebase-ui-auth:3.3.1' 

我希望它有所帮助。

我有同样的错误。 我在用

  implementation 'com.firebaseui:firebase-ui-auth:3.2.2' 

我解决了它更新到

  implementation 'com.firebaseui:firebase-ui-auth:3.3.0' 

另一个可能的原因/修复可能是项目级别的build.gradle

 buildscript { repositories { google() jcenter() } dependencies { classpath 'com.android.tools.build:gradle:3.1.0' classpath 'com.google.gms:google-services:3.2.0' // NOTE: Do not place your application dependencies here; they belong // in the individual module build.gradle files } 

}

这很无聊。 Google应该更好地审核这些更新。 我尝试了一切,但我的问题只能通过返回Google Play服务API的版本来解决:

implementation 'com.google.android.gms:play-services-gcm:11.8.0'