无法使用Travis CI / Android SDK v20上的支持库构建

我希望这不应该太具有挑战性,但是:

目前我正在尝试在Android / Travis CI中构建一个项目,你可以在这里find它。 我正在尝试使用Android L开发人员预览版,并使用Travis-CI进行构建。 我希望使用Gradle SDK Manager插件可以让我这样做。 不幸的是,事实并非如此。 我不知道我的build.gradle文件是否设置不正确,或者是什么,但我希望有人可以指出我正确的方向。

构建错误 :

FAILURE: Build failed with an exception. * What went wrong: A problem occurred configuring project ':app'. > Could not resolve all dependencies for configuration ':app:_testConfigDebugCompile'. > Could not find any version that matches com.android.support:appcompat-v7:20.+. Required by: MinimalBible:app:unspecified 

build.gradle :

 buildscript { repositories { mavenCentral() } dependencies { classpath 'com.jakewharton.sdkmanager:gradle-plugin:0.10.+' } } apply plugin: 'android-sdk-manager' apply plugin: 'com.android.application' android { compileSdkVersion 20 buildToolsVersion '20.0.0' defaultConfig { applicationId 'org.bspeice.minimalbible' minSdkVersion 8 targetSdkVersion 20 versionCode 1 versionName '1.0' } buildTypes { release { runProguard false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } } dependencies { compile 'com.squareup.dagger:dagger:1.2.1' provided 'com.squareup.dagger:dagger-compiler:1.2.1' compile 'com.android.support:appcompat-v7:20.+' } 

如果需要任何进一步的信息,请与我们联系。

尝试这样的事情:

 dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) //force complie with 20.0.0 compile ('com.android.support:appcompat-v7:20.0.0'){force = true} compile 'com.nostra13.universalimageloader:universal-image-loader:1.9.1' }