使用约束库的版本1.0.0-alpha7,这是过时的

我开始使用Android Studio 2.2并尝试使用ConstraintLayout,但是当我让android studio自动添加它时,显示出错误

Using version 1.0.0-alpha7 of the constraint library, which is obsolete 

当我尝试使用快速修复进行升级时,我得到了这个错误

 Error:Could not find com.android.support.constraint:constraint-layout:1.0.0-alpha8. 

我认为这是Android Studio中的一个错误。 我该怎么办才能解决这个问题?

我目前的解决办法是压制这个错误。

Solutions Collecting From Web of "使用约束库的版本1.0.0-alpha7,这是过时的"

您需要在SDK Manager SDK Tools类别的Support Repository包中安装ConstraintLayout for Android

FileSettingsAppearance & BehaviorSystem SettingsAndroid SDK

请记住select“显示详细信息”。 你应该看到最新版本的约束布局。 在这里输入图像说明

您收到此警告是因为您使用older version的约束布局,而您有newer version可用。 转到您的sdkpipe理器 – > sdk工具 – > 支持仓库 – > ConstraintLayout对于Android ,然后勾选Show Package Detailscheckbox来查找约束布局的可用版本并安装最新版本并更新您的build.gradle(App Level)

到目前为止,最新版本是constraint-layout:1.0.2所以使用这个。