我如何检测我的应用程序中的任何版本?

我用SDK 1.6创build应用程序,我想,如果我的应用程序运行在Android 3:做,我使用这些代码,但错误告诉我HONEYCOMB无法解决或不是一个领域。

这里是我的代码:

 if (Build.VERSION.RELEASE == Build.VERSION_CODES.HONEYCOMB) { // do anything... } else { // do anything... } 

Related of "我如何检测我的应用程序中的任何版本?"

要在编译时识别Build.VERSION_CODES.HONEYCOMB ,您需要将构build目标设置为API Level 11或更高。 在Eclipse中,这是在你的项目属性的Android部分; 对于命令行版本,这是在default.properties