最新的ADT和SDK工具安装,但仍然要求最新的SDK工具

我刚刚安装了Eclipse Juno,并安装了ADT插件20.0.3,但每次eclipse发布时都会收到这样的消息:“此版本的ADT需要修订版20.0.0或更高版本的android sdk工具,当前版本为18.0.0。请升级您的sdk到最新版本“。我在偏好指向的sdk工具是最新的,因为明天我正在使用Eclipse Indigo(也安装了ADT 20.0.3),并且更新了所有sdk工具。我只是指出Juno中的同一个sdk文件夹,请帮忙谢谢

Solutions Collecting From Web of "最新的ADT和SDK工具安装,但仍然要求最新的SDK工具"

实际上,解决scheme不涉及整个安装程序的删除或下载。 在更新Eclipse ADT之后,您只需在SDKpipe理器中更新SDK工具。 诀窍是打开SDKpipe理器 – >软件包菜单 – >重新加载。 那么最新的版本将可以更新。 就这么简单,但起初实际上很烦人。

我也遇到了这个问题,除了我是为了ADT 21而得到的,消息如下:

“此版本的ADT需要Android SDK工具修订版21.0.0 rc9或更高版本”。

我无法使用SDK Manager更新到SDK工具21.0.0 rc9。 我发现我必须通过下载installer_r1-windows.exe来重新安装适用于Windows的SDK工具

我在Get the Android SDK页面find了这个链接。

安装完成后,我的SDK Manager显示SDK Tools 21正在安装,并提供了下载Android 4.2平台的选项。

我遇到过同样的问题,

转到C:// – > Program Files – > Android

那里应该只有一个文件夹,我有不止一个(从以前的SDK下载)。

Eclipse是困惑的,并使用错误的。 删除过期的文件夹,保留最近的SDK下载。

重新启动Eclipse,它应该popup一个错误,说它找不到你的SDK文件夹。 它会给你一个标有“偏好”的button。 转到首选项,并将path调整到程序文件中find的唯一文件夹 – > android。

尽pipe我已经在Eclipsenetworking设置中设置了代理设置,但它们并未被SDKpipe理器使用。 SDKpipe理器在“工具 – >选项”下有它自己的。 如果在将来的版本中使用默认的Eclipse代理设置来避免这个问题,那将是非常好的。