Android 2.2.1,2.3,2.0中的碎片。 这可能吗?

基本上我想知道如果我们可以在Android操作系统<3.0的设备中有片段布局。

我的应用程序顶部有5个不同的button,开始总是第一个button被默认点击,所以这些button下方的视图是第一个视图。 现在当你点击它旁边的第二个button时,我不希望标题图像被刷新,但它下面的视图需要刷新。 所以它像更新标题图像button下面的片段。

所以我们可以在OS <3.0的设备上安装Android的片段。

萨纳。

Solutions Collecting From Web of "Android 2.2.1,2.3,2.0中的碎片。 这可能吗?"

您必须使用Google提供的兼容性库。 以下是如何在设备上使用碎片<3.0

  • 打开Eclipse
  • Window-> Android SDK和AVD
  • 可用的软件包 – > Android支持包(安装这个)

安装完成后,右键单击要添加Fragment支持的Android项目。

  • 构buildpath – >configuration构buildpath
  • “库”选项卡
  • 添加外部JAR
  • 添加android-support-v4.jar(应该在extras / android / support / v4下的android下载文件夹中

现在你的应用程序支持碎片。 使用SDK 3.0以上版本的兼容软件包有一些关键的区别。 例如

  1. 使用片段的活动类必须扩展FragmentActivity NOT Activity
  2. 而不是getFragmentManager()你必须使用getSupportFragmentManager

请享用!!!

是的,Android 1.6支持片段。 有关更多信息,请参阅: 兼容性库 。

在Eclipse Indigo中,您可以右键单击该项目 – > Android工具 – >添加支持库。 然后,而不是使用import android.app.Fragment OS> 3.0,使用import android.support.v4.app.Fragment;

对于Android Studio,您需要右键单击应用程序名称>打开模块设置>依赖项选项卡>单击“+”添加依赖项。

你需要在你所有的片段中join这个:

 import android.support.v4.app.Fragment; 

将其导入到MainActivity中:

使用这个import android.support.v4.app.FragmentManager; 而不是import android.app.FragmentManager;

而不是getFragmentManager()你必须使用getSupportFragmentManager();

是的,Android提供了向后兼容的支持库。 select项目 – >右键 – > android工具 – >添加支持库