Android中的应用内结算 – 问题

我有几个有关Android应用内结算的问题,因为我无法在文档中find所需的东西。

1:需要Android 1.6或更高版本,市场2.3或更高。 如果我拥有的设备没有被植入,我怎样才能手动安装Android Market 2.3?

2:我在Android 2.2和Market 2.2.11上试过,但是在阅读Bundle响应时出现错误。

3:它是否有机会在模拟器上运行?

4:为了testing应用程序内购买,我真的必须做些什么? 我下载了示例应用程序,并编译它,但我甚至无法得到我的静态响应(市场应用程序2.2.11)。

5:实际上,在具有较低Api级别的设备上安装Android Market 2.3是否合法? 谷歌说,你需要Droid 1.6 SDK和市场2.3,但据我所知没有(或很less)设备与市场2.3运行2.3 Android以下。 你能更新你的市场应用程序?

6:(跛)Android Market客户端自动更新自己,当我新的一个被释放?

Solutions Collecting From Web of "Android中的应用内结算 – 问题"

  1. 您不必手动安装市场2.3.0,市场应用程序应该在新版本发布时自行更新。

  2. 你已经说过它需要市场2.3.0,所以显然它不会在2.2.11工作。

  3. 很多人都在模拟器上运行市场,所以它可能会工作: 如何在模拟器上安装Android Market应用程序?

  4. 请参阅问题2.同样,即使您有Market 2.3.0,我也不确定Google是否已启用testing阶段。 我也想用在应用程序购买,但我不打算花费几个月的时间来尝试。

  5. 我相信所有的设备都将获得Market 2.3.0,而不仅仅是那些运行Android 2.3的设备,因为它只是一个应用程序而不是操作系统的一部分,但我可能是错的。

  6. 是。