Android:由于依赖冲突,无法完成安装

我正在安装新的软件,使用此链接: https : //dl-ssl.google.com/android/eclipse/

但总是得到:操作无法完成。 看到细节。

Cannot complete the install because of a conflicting dependency. Software being installed: Android DDMS 23.0.2.1259578 (com.android.ide.eclipse.ddms.feature.feature.group 23.0.2.1259578) Software currently installed: Android DDMS 22.6.2.v201403212031-1085508 (com.android.ide.eclipse.ddms.feature.group 22.6.2.v201403212031-1085508) Only one of the following can be installed at once: Dalvik Debug Monitor Service 23.0.2.1259578 (com.android.ide.eclipse.ddms 23.0.2.1259578) Dalvik Debug Monitor Service 22.6.2.v201403212031-1085508 (com.android.ide.eclipse.ddms 22.6.2.v201403212031-1085508) Cannot satisfy dependency: From: Android DDMS 23.0.2.1259578 (com.android.ide.eclipse.ddms.feature.feature.group 23.0.2.1259578) To: com.android.ide.eclipse.ddms [23.0.2.1259578] Cannot satisfy dependency: From: Android DDMS 22.6.2.v201403212031-1085508 (com.android.ide.eclipse.ddms.feature.group 22.6.2.v201403212031-1085508) To: com.android.ide.eclipse.ddms [22.6.2.v201403212031-1085508] 

Solutions Collecting From Web of "Android:由于依赖冲突,无法完成安装"

这是一个包装错误。 整个proguard文件丢失。 我们将尽快更新,但在此之前只需从以前版本的工具中复制即可:

 http://dl.google.com/android/android-sdk_r22.6.2-linux.tgz http://dl.google.com/android/android-sdk_r22.6.2-windows.zip http://dl.google.com/android/android-sdk_r22.6.2-macosx.zip 

并复制以下文件:

 tools/hprof-conv tools/support/annotations.jar tools/proguard 

所以最后如果你从一个新的ADT副本手工开始的文件:)

编辑:最新的ADT版本,该软件包现在应该与自动更新,所以安装这些新版本:

 linux 64 bit vm: http://dl.google.com/android/adt/adt-bundle-linux-x86_64-20140702.zip linux 32 bit vm: http://dl.google.com/android/adt/adt-bundle-linux-x86-20140702.zip mac: http://dl.google.com/android/adt/adt-bundle-mac-x86_64-20140702.zip win32: http://dl.google.com/android/adt/adt-bundle-windows-x86-20140702.zip win64: http://dl.google.com/android/adt/adt-bundle-windows-x86_64-20140702.zip 

不要试图从以前的版本升级,因为它根本不工作。 如果你有zipalign的问题,它现在在平台工具下,没有更多的工具/ /所以你可以做一个符号链接或只是将其复制到预期的文件夹。

信贷到@ greywolf82在这里回答: 用Android开发工具 v。23 更新Eclipse

信贷去@MarcoDuff在这里回答: 无法完成安装,因为依赖冲突