警告:忽略Android API工件com.google.android:android:4.1.1.4

今天上午,Android Studio将外部库添加到我的项目中。 现在当我build立我的项目时,

Warning:Ignoring Android API artifact com.google.android:android:4.1.1.4 for debug 

有谁知道这是什么意思?

Solutions Collecting From Web of "警告:忽略Android API工件com.google.android:android:4.1.1.4"

有谁知道这是什么意思?

项目的一些依赖项已经直接声明了对Android版本的依赖。

修理

要find违规的依赖项,请遵循以下步骤,最好告诉图书馆的作者有关错误。 您也可以在等待修复时明确避免该问题:

运行./gradlew app:dependencies并find一行或多行说:

 +--- com.awesome:someawesomelibrary:1.0.0.0 | +--- com.google.android:android:4.1.1.4 

如果这个输出太长找不到,请记住你可以通过添加> out.txt将其输出到一个文本文件

现在find您的gradle导入com.awesome:someawesomelibrary:1.0.0.0并排除像这样的android

 compile ('com.awesome:someawesomelibrary:1.0.0.0') { exclude group: 'com.google.android', module: 'android' }