Android cmake是否兼容较新的NDK版本?

我有兴趣将一个cmake脚本移植到Android,到目前为止我已经find了这个项目 ,问题是它看起来很老,在安装文件中只有NDK r5b的引用,这是一个真正的老发布。

有替代的Android构build脚本?

Solutions Collecting From Web of "Android cmake是否兼容较新的NDK版本?"

文档从一开始就没有更新,但实际上该项目的工具链文件支持从r5r8b所有NDK版本,并在明确指向其位置时与r8c一起使用。

如果您需要完全支持NDK r8cfunction(包括Clang编译器),那么您可以从GitHub的fork中获取CMake工具链的最新版本: https : //github.com/taka-no-me/android-cmake