Android SDK需要android开发人员工具包版本17.0.0或更高版本

当我试图将我的项目从eclipse合并到netbeans时,我遇到了这个奇怪的问题。 现在当试图重新运行eclipse我得到这个错误

“Android SDK需要android开发人员工具包版本17.0.0或更高”

我试图解决这个问题的方法是尝试更新其中的SDK和工具包。

到目前为止,一切都是更新的,现在我是无能的。

启动eclipse时出现错误信息

Solutions Collecting From Web of "Android SDK需要android开发人员工具包版本17.0.0或更高版本"

在Eclipse中运行软件更新(帮助>检查更新)并更新ADT。

进入你的eclipse,点击帮助 – >安装新软件 – >添加… – >input'ADT plugin'作为名字,input' https://dl-ssl.google.com/android/eclipse/ '对于URL,那么包括ADT在内的一对select会出现在窗口中,点击你想要更新的东西,然后点击确定,你将能够更新你的ADT。

  1. 在Eclipse中去帮助。
  2. 安装新软件—>在添加仓库中添加编写名称:ADT和位置: https : //dl-ssl.google.com/android/eclipse/
  3. 加载后你将得到开发工具和NDK插件
  4. 检查你是否想要或检查开发工具。
  5. 点击下一步

有同样的问题。 尝试通过“帮助”>“检查更新”进行更新,但收到如下警告消息:

联系软件站点遇到问题

之后更新过程失败。 Googlesearch并find解决scheme。

您只需要在位于Eclipse文件夹中的eclipse.ini中添加一行。 将此行添加到文件的末尾:

-Djava.net.preferIPv4Stack=true 

之后更新过程正常进行。

问题在于上传过程通过IPv6,而互联网服务提供商支持IPv4。

来源(俄语)

只需更新您的Android开发人员工具包。 它通过附带的GUI更新器/pipe理器自动完成。

首先更新你的Android SDK(看起来你已经这样做了)然后执行更新Eclipse

Eclipse更新之后,确保你已经安装了最新的Android插件。

最后,在Android SDK Manager插件中,确保您更新的Android SDK的path是正确的。

添加存储库后,我看到以下消息:无法通过https://dl-ssl.google.com/android/eclipse/content.xml读取存储库。 无法通过https://dl-ssl.google.com/android/eclipse/content.xml读取存储库。 sun.security.validator.ValidatorException:PKIXpath构build失败:sun.security.provider.certpath.SunCertPathBuilderException:无法find有效的证书path到请求的目标