Android Studio中的“Subversion命令行客户端版本太旧”错误

每当我在Android Studio中打开一个项目时,我都会看到这个错误:

错误

当我点击“修复它”时,它将显示以下窗口:

修理它

我不知道该怎么办,因为我正在运行TortoiseSVN 1.9.0 ,这是最新版本

我该怎么做才能解决这个错误? 谢谢你的帮助。

Solutions Collecting From Web of "Android Studio中的“Subversion命令行客户端版本太旧”错误"

这只是印刷错误:必须“太新”

Android Studio基于Intellij IDEA, Intellij 14.1.4无法使用svn 1.9.0

Intellij IDEA 14可与SVN 1.9配合使用,只显示警告: https ://youtrack.jetbrains.com/issue/IDEA-140754

Svn 1.9命令行客户端应该在IDEA中工作 – 只显示警告(可以关闭它)。 从https://confluence.jetbrains.com/display/IDEADEV/IDEA+14.1+EAP或15 EAP升级新版本14.1.5: https : //confluence.jetbrains.com/display/IDEADEV/IDEA+15+EAP 。

https://devnet.jetbrains.com/thread/471975

正如Lazy Badger所说,它应该说is too new

在Debian上面临同样的问题。 我安装了1.9版本。 我通过删除已安装的版本然后安装1.8版本来修复它:

 aptitude remove subversion aptitude install subversion=1.8.10-6+deb8u1 

编辑
据我了解,Android Studio的开发者已在最新版本中解决了这个问题。

在我的情况下,它与破碎的路径有关:

 xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun 

安装xcode-select后解决问题: xcode-select --install