在android studio导入项目时得到错误?

最近我更新我的android工作室到0.30我试图在android studion导入项目。

项目正在使用旧版本的Android Gradle插件。 支持的最低版本是0.6.1。

请在您的build.gradle文件中更新依赖项“com.android.tools.build:gradle”的版本。

请参阅IDE日志以获取更多详细信息(帮助|显示日志)

第二个错误

您正在使用一个旧的,不受支持的Gradle版本。 请使用1.8或更高版本。 请在项目的Gradle设置或中指向支持的Gradle版本
该项目的Gradle包装器(如果适用)。请参阅IDE日志以获取更多详细信息(帮助|显示日志

第三个错误

无法使用Gradle发行版“ http://services.gradle.org/distributions/gradle-1.6-bin.zip ”执行构build。 生成文件'C:\ Users \ Asthme \ crushersblue1 \ babies \ build.gradle'行:8

找不到参数的方法classpath()
[com.android.tools.build:gradle:0.6.+]关于项目':crushersblue1:babies'。

请参阅IDE日志以获取更多详细信息(帮助|显示日志)

Solutions Collecting From Web of "在android studio导入项目时得到错误?"

步骤1:将build.gradle中的行改为:

dependencies { classpath 'com.android.tools.build:gradle:0.6.+' } 

第2步:

YourProject.iml文件中,删除整个component name="FacetManager"标签。

第3步

(也许不是必需的):在Android SDKpipe理器中,安装(如果尚未安装)附加程序下的Android支持库。

参考这个

我能够通过使用我的gradle目录的文件path来解决这个问题:

C:\ Users \用户xxxx.gradle \包装\ dists目录\ gradle这个-1.12-ALL \ 2apkk7d25miauqf1pdjp1bm0uo \ gradle产出1.12

import继续良好。

这是无法将Eclipse项目导入到Android Studio (使用默认Gradle包装器时)

我必须在gradle/wrapper/gradle-wrapper.properties编辑gradle包装器设置gradle/wrapper/gradle-wrapper.properties gradle版本更改为1.8。

./gradle/wrapper/gradle-wrapper.properties:

 #Wed Apr 10 15:27:10 PDT 2013 distributionBase=GRADLE_USER_HOME distributionPath=wrapper/dists zipStoreBase=GRADLE_USER_HOME zipStorePath=wrapper/dists distributionUrl=http\://services.gradle.org/distributions/gradle-1.8-bin.zip 

我不得不将gradle-1.6-bin.zip 改成gradle-1.8-bin.zip 。 我猜从生成这个文件的eclipse的旧的ADT插件仍然使用旧的URL。

如果所有其他解决scheme在这里不工作(他们都是从3天前)…我发现…

我在我的settings.gradle中有二级项目,每个项目都有自己的build.gradle。 Android Studio IDE说,你需要更新到0.6.1,但它只指向第一个项目build.gradle – 我不得不手动find这些项目的辅助build.gradle文件,并确保所有0.6。+而不是以前的版本。

将gradle更改为0.6。+正如lingbuild议的那样,并且在gradle-wrapper.properties文件中,将distributionUrl更改为http\://services.gradle.org/distributions/gradle-1.8-bin.zip