Android Studio 2.0 – 插件太旧,请更新到更新版本,或将ANDROID_DAILY_OVERRIDE环境variables设置为

我更新了Android Studio版本2.0并正常使用。 当我今天创build一个新的项目时,它显示错误插件太旧,请更新到一个更新的版本,或设置ANDROID_DAILY_OVERRIDE环境variables

我意识到只有当我创build一个新项目时才会出现这个问题。 在以前开发的项目中,问题不会发生,我意识到gradle是不同的classpath 'com.android.tools.build:gradle:1.3.0' :gradle:1.3.0 classpath 'com.android.tools.build:gradle:1.3.0'

我必须更新一套旧的项目?

我的应用程序/ build.gradle

 apply plugin: 'com.android.application' android { compileSdkVersion 23 buildToolsVersion "23.0.2" defaultConfig { applicationId "luizugliano.com.br.teste" minSdkVersion 16 targetSdkVersion 23 versionCode 1 versionName "1.0" } buildTypes { release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } } dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) testCompile 'junit:junit:4.12' compile 'com.android.support:appcompat-v7:23.1.1' compile 'com.android.support:design:23.1.1' } 

我的build.gradle(项目)

 // Top-level build file where you can add configuration options common to all sub-projects/modules. buildscript { repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:2.0.0-alpha1' // NOTE: Do not place your application dependencies here; they belong // in the individual module build.gradle files } } allprojects { repositories { jcenter() } } task clean(type: Delete) { delete rootProject.buildDir } 

Solutions Collecting From Web of "Android Studio 2.0 – 插件太旧,请更新到更新版本,或将ANDROID_DAILY_OVERRIDE环境variables设置为"

UH OH,Google公告: “本网站不再提供Android Studio下载。”

(旧的“频道”链接不再有效,此答案中的链接已更新为新格式,请确保在您使用这些新格式时更改您的书签)

您需要更新您正在构build的gradle工具的版本。 这可以在build.gradle的dependencies部分中build.gradle您有3个选项可以更新到

截至2017年3月2日发布频道中引用的最新稳定版本

 classpath 'com.android.tools.build:gradle:2.3.0' 

或者是截至2017年2月15日的预览频道的最新testing版

 classpath 'com.android.tools.build:gradle:2.3.0-beta4' 

截至2017年3月21日, 预览频道的最新alpha版本也为您提供了使用选项

 classpath 'com.android.tools.build:gradle:2.4.0-alpha3' 

更新要求您也升级gradle包装 。 截至17年2月20日,最新的是:

 distributionUrl=https\://services.gradle.org/distributions/gradle-3.4-all.zip 

在android工作室,你可以find你的包装通过改变到项目视图,并寻找gradle / wrapper / gradle-wrapper.properties

有时在更改包装器之后,项目将无法编译,如“Minimum supported Gradle version is 2.14.1. Current version is 2.10. Try changing Gradle distribution version to...” “Minimum supported Gradle version is 2.14.1. Current version is 2.10. Try changing Gradle distribution version to...” “Minimum supported Gradle version is 2.14.1. Current version is 2.10. Try changing Gradle distribution version to...”尽pipe在gradle-wrapper.properties中已经有了正确的版本。 如果发生这种情况请尝试以

转到设置 > 构build,执行,部署 > Gradle

在“ Project-level settings确保使用默认Gradle包装(推荐)为选定选项,然后重新构build项目。

(另外注意:关于alpha版本和beta版本 – 当我检查时,并不总是有一个比stable版本更新的版本,在这种情况下,我只给出了以前版本的值,这可以让你回滚到版本如果您遇到发行版本的问题)

在新项目中改变这个部分:

 dependencies { classpath 'com.android.tools.build:gradle:2.0.0-alpha1' 

 dependencies { classpath 'com.android.tools.build:gradle:1.5.0'. 

如果您没有经验的用户,请坚持使用Android Studio的更新稳定频道。 我想你从Canary Channel获得了Android Studio。

注意:

Android Studio 的Canary频道大致上每周都会提供最新的更新。 尽pipe这些版本都经过了testing,但是它们仍然存在缺陷,因为我们希望人们尽快看到新的东西。

来自: http : //tools.android.com/download/studio/canary

您不需要更改旧项目的依赖关系。 他们应该在最新版本上正常运行。

同样的问题更新。 这个修复了我的问题:[build.gradle]

  classpath 'com.android.tools.build:gradle:2.0.0-alpha3' 

要么

  classpath 'com.android.tools.build:gradle:2.0.0-beta2' 

只需在Windows属性的“高级系统设置”中,添加一个名称为ANDROID_DAILY_OVERRIDE的新环境variables,并在错误消息中给出值。 重新启动android工作室,你会准备好去

在这里输入图像说明

截至2016年4月5日,这工作对我来说:

 classpath 'com.android.tools.build:gradle:2.0.0-rc3' 
 classpath: com.android.tools.build:gradle:+ 

这将通过更新gradle到最新的解决这个问题。

然而,这是危险的(将在alpha阶段代码),也会发出警告。

如果您使用的是Android Studio 2.0 Preview,我可以build议使用'beta'更新频道而不是'stable'。 它将允许您接收最新的gradleconfiguration更改。 您可以在SettingsAppearance & BehaviorSystem SettingsUpdates更改更新频道。 selectAutomatically check updates for [Beta Channel]

为了了解gradle classpathdistributionUrl实际版本(检查Nick Caroso的答案 ),你可以创build一个新的空项目并在那里看到这些值。

你需要的gradle版本变成了

 classpath 'com.android.tools.build:gradle:2.0.0-beta7' 

这要求你使用2.10gradle wrapper,如果你还在使用以前的版本

 distributionUrl=https\://services.gradle.org/distributions/gradle-2.10-all.zip 

在android工作室,你可以find你的包装通过改变到项目视图,并寻找gradle/wrapper/gradle-wrapper.properties

您需要更改您的应用程序的gradle / wrapper文件夹中的gradle-wrapper.properties文件,请更改您的distributionUrl,如下所示:

 distributionUrl=http\://services.gradle.org/distributions/gradle-2.8-all.zip 

根据您的要求使用http:或https:\。 然后干净你的项目,你就完成了!

边注 :

 classpath 'com.android.tools.build:gradle:2.0.0-alpha3' 

现在可用,如果你想使用最新版本。

你也可以利用android studio的即时运行function,这在2.0.0以下的gradle版本中是不可用的

Android Studio 2.0有一个更新项目来使用即时运行。 对于像我这样小脑子的人来说:

http://tools.android.com/tech-docs/instant-run

Android Studio 2.0的当前版本是Beta 6。

尝试更新gradle到2.10

对于Mac,临时path是Android Studio>首选项>构build,执行,部署>构build工具> Gradle

当然你必须先下载gradle 2.10

我得到了与'com.android.tools.build:gradle:2.2.0-alpha2'和gradle wrapper 2.10在04/07/2016相同的错误然后,我只是改变

 'com.android.tools.build:gradle:2.2.0-alpha3' 

现在我没有问题。

希望这个帮助peple。

我已经这样解决了。

脚步:

  1. 打开gradle-wrapper.properties文件并将distributionUrl更改为https\://services.gradle.org/distributions/gradle-2.14.1-all.zip
  2. 打开根级 build.gradle并将classpath更改为com.android.tools.build:gradle:2.2.2
  3. 同步您的Android演播室项目。

参考屏幕截图:

在这里输入图像说明

完成。

只要改变classpath'com.android.tools.build:gradle:2.0.0-alpha'或

 classpath 'com.android.tools.build:gradle:2.1.0' 

我改变我的类path从'com.android.tools.build:gradle:2.2.0-alpha4'

到类path“com.android.tools.build:gradle:2.2.0-alpha5”

当警告出现“无法findcaching的类path”时点击“try_again”,你只需点击“同步”,这就像一个微风。

这个问题通常发生在IDE(android studio)中,其中的项目是build立和项目不兼容的gradle插件。请检查下面的链接http://tools.android.com/tech-docs/new-build-系统/版本兼容性

在我的情况下,我已经创build了一个使用AS 1.0 / 2.0版本的项目,后来导入新版本的工作室,它给了我错误,然后我打开项目在旧版本的AS工作。 你也可以查看http://tools.android.com/tech-docs/new-build-system

文件 – >项目结构 – >项目 – > Android插件版本= 2.2.3

正常工作的Android Studio 2.2.3