Android Studio 3.0 Canary 5 – 错误:无法加载类'org.gradle.api.internal.component.Usage'

我已经读过所有关于这个问题的现有堆栈问题,他们的解决scheme并没有帮助我。

  • 这个问题已经很明显,因为所有AS更新超过2.3。
  • 创build一个新的项目是好的,并build立
  • 我试图复制“新项目”中的所有值,但仍然存在

错误:

错误:无法加载类“org.gradle.api.internal.component.Usage”。 这种意外错误的可能原因包括:

  • Gradle的依赖关系caching可能已损坏(有时发生在networking连接超时之后)。重新下载依赖项并同步项目(需要networking)
  • Gradle构build过程(守护进程)的状态可能已损坏。 停止所有的Gradle守护进程可能会解决这个问题。 停止Gradle构build过程(需要重新启动)
  • 您的项目可能使用与项目中的其他插件或项目请求的Gradle版本不兼容的第三方插件。

在损坏的Gradle进程的情况下,您也可以尝试closuresIDE,然后杀死所有的Java进程。

gradle-wrapper.properties

distributionBase=GRADLE_USER_HOME distributionPath=wrapper/dists zipStoreBase=GRADLE_USER_HOME zipStorePath=wrapper/dists distributionUrl=https\://services.gradle.org/distributions/gradle-4.1-milestone-1-all.zip 

项目build.gradle

 buildscript { repositories { google() jcenter() } dependencies { classpath 'com.android.tools.build:gradle:3.0.0-alpha5' classpath "io.realm:realm-gradle-plugin:0.89.1" } } allprojects { repositories { google() jcenter() maven { url 'https://jitpack.io' } } } task clean(type: Delete) { delete rootProject.buildDir } 

设置Gradle

 Use default gradle wrapper 

模块设置

 Compile Sdk Version: API 26 Build Tools Version: 26.0.0 

我相信这些都是最新的。 我已经尝试无效的caching和重新启动/重新启动机器

Solutions Collecting From Web of "Android Studio 3.0 Canary 5 – 错误:无法加载类'org.gradle.api.internal.component.Usage'"

我尝试了所有上述删除caching的build议,没有为我工作。 最后,问题是插件com.novoda:bintray-release:0.4.0 。 当我升级到0.5.0 ,它的工作。

我会仔细看看你的gradle插件!

删除GradlecachingC:/users/<yourname>/.gradle (实际删除整个目录)。 然后升级Gradle并重试。

或者,如果您正在使用Gradle包装进入属性并升级包装的版本./gradle/wrapper/gradle-wrapper.properties

你的问题没有指定版本,那么我认为这可能是你的问题。

编辑:检查你的插件是否仍然与您的Gradle版本兼容

io.realm:realm-gradle-plugin:0.89.1似乎有点老了3.5.0版已经有了

由于Gradle 3.4 Usage被重命名为UsageContext ,可能是您的插件之一,或者依赖关系与通过查看分发Url所使用的Gradle 4.1-milestone不兼容。