Android Studio – 无法应用插件

我正在开发一个应用程序。 在我的应用程序中没有代码错误,但是当我尝试运行我的项目时,它给出了以下错误。

错误:(1,1)评估项目':app'时发生问题。

无法应用插件[id'com.android.application']

无法创build“AppPlugin”types的插件。

我试试这个也是Gradle发出一个错误“无法创buildtypes'AppPlugin'的插件”

这也是Android Studio中的Gradle错误

以下是我的build.gradle文件

apply plugin: 'com.android.application' apply plugin: 'com.google.gms.google-services' android { compileSdkVersion 23 buildToolsVersion "21.1.2" defaultConfig { applicationId "com.praval.healthfreak" minSdkVersion 15 targetSdkVersion 23 versionCode 1 versionName "1.0" } buildTypes { release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } } dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) testCompile 'junit:junit:4.12' compile 'com.android.support:appcompat-v7:23.2.1' compile 'com.google.android.gms:play-services:8.3.0' compile 'de.hdodenhof:circleimageview:1.3.0' compile 'com.android.support:design:23.2.1' compile files('libs/YouTubeAndroidPlayerApi.jar') } 

Solutions Collecting From Web of "Android Studio – 无法应用插件"

2017年10月31日更新

你需要更新到最新的gradle版本来解决这个问题。

请确保您使用的是最新的Android Studio 3.0

从这里获取最新的Gradle 4.3

然后通过添加这个依赖gradle.build来更新你的项目级别gradle.build

 buildscript { repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:3.0.0' } } 

gradle会更新造成问题的构build工具。

注意:如果您使用Android Studio 2.3或更低版本,请使用

classpath 'com.android.tools.build:gradle:2.3.3'

你只需要改变你的project.gradle文件。 并同步你的Gradle。

 dependencies { classpath 'com.android.tools.build:gradle:2.2.2' } 

在Android Studio上打开该项目,让它为您解决问题

它立即显示在左下方:

在这里输入图像说明

然后点击该链接,它会为您修复正确的文件。

这最终修复了以上提到的Gradle版本: https : //stackoverflow.com/a/37091489/895245,但它也修复了更多的错误,所以这是最简单的事情。

testing在https://github.com/googlesamples/android-vulkan-tutorials/tree/7ba478ac2e0d9006c9e2e261446003a4449b8aa3/tutorial05_triangle,Android Studio 2.3,Ubuntu 14.04。