Android Studio Gradle问题升级到版本0.5.0 – Gradle从0.8迁移到0.9 – Android Studio升级到0.8.1

升级后的消息状态:

Failed to refresh Gradle project 'XXX' The project is using an unsupported version of the Android Gradle plug-in (0.8.3). Version 0.9.0 introduced incompatible changes in the build language. Please read the migration guide to learn how to update your project. 

升级到Android Studio版本> = 0.8.0后出现同样的问题

Solutions Collecting From Web of "Android Studio Gradle问题升级到版本0.5.0 – Gradle从0.8迁移到0.9 – Android Studio升级到0.8.1"

Android Studio 0.5.0需要gradle-plugin 0.9.0

Gradle-plugin 0.9.0可以与Gradle 1.10或Gradle 1.11一起使用

按照Cedric的build议修改您的build.gradle脚本。

gradle-plugin和gradle版本之间有一个关系。 例如

更新至27/11/2015

 com.android.tools.build:gradle:0.6.+ -> gradle 1.8 com.android.tools.build:gradle:0.7.+ -> gradle 1.9 com.android.tools.build:gradle:0.8.+ -> gradle 1.9/1.10 com.android.tools.build:gradle:0.9.+ -> gradle 1.10/1.11 com.android.tools.build:gradle:0.10.+ -> gradle 1.10/1.11/1.12 com.android.tools.build:gradle:0.11.+ -> gradle 1.10/1.11/1.12 com.android.tools.build:gradle:0.12.+ -> gradle 1.10/1.11/1.12 com.android.tools.build:gradle:0.13.+ -> gradle 2.1 com.android.tools.build:gradle:0.14.+ -> gradle 2.1 com.android.tools.build:gradle:1.0.+ -> gradle 2.2.1-2.3 com.android.tools.build:gradle:1.1.+ -> gradle 2.2.1-2.3 com.android.tools.build:gradle:1.2.+ -> gradle 2.2.1+ com.android.tools.build:gradle:1.3.+ -> gradle 2.2.1+ com.android.tools.build:gradle:1.3.+ -> gradle 2.2.1+ com.android.tools.build:gradle:1.5.+ -> gradle 2.2.1+ com.android.tools.build:gradle:2.0.+ -> gradle 2.10.0+ 

您可以在gradle/wrapper/gradle-wrapper.properties文件中find项目中使用的gradle版本

gradle-plugin和IDE版本之间也有关系。

 Android Studio 0.3.x -> gradle-plugin 0.6 Android Studio 0.4.x -> gradle-plugin 0.7 Android Studio 0.4.3+ -> gradle-plugin 0.8 Android Studio 0.5.x -> gradle-plugin 0.9 Android Studio 0.5.8 -> gradle-plugin 0.9.+ or 0.10.+ Android Studio 0.5.9 -> gradle-plugin 0.9.+ or 0.10.4+ Android Studio 0.6.x -> gradle-plugin 0.11.+ Android Studio 0.8.x -> gradle-plugin 0.12.+ Android Studio 0.8.11+ -> gradle-plugin 0.13.+ / gradle-plugin 0.12.+ Android Studio 0.9.x -> gradle-plugin 0.14.+ Android Studio 1.0.0 -> gradle-plugin 1.0.0 Android Studio 1.1.x -> gradle-plugin 1.0.0/ 1.1.x / 1.2.x Android Studio 1.2.x -> gradle-plugin 1.0.0/ 1.1.x / 1.2.x Android Studio 1.3.x -> gradle-plugin 1.0.0/ 1.1.x / 1.2.x / 1.3.x Android Studio 1.4.x -> gradle-plugin 1.0.0/ 1.1.x / 1.2.x / 1.3.x Android Studio 1.5.x -> gradle-plugin 1.0.0/ 1.1.x / 1.2.x / 1.3.x / 1.5.x Android Studio 2.0.x -> gradle-plugin 2.0.0 Also gradle 1.12 requires Android Studio 0.5.8+ 

对于更新的新闻,你可以检查这个链接: http : //tools.android.com/recent
有关Gradle插件的更新文档, 请点击这里 。

如果您更改插件版本,请检查兼容性,然后单击同步项目与您的gradle files.It将下载一个新的插件版本,如果您需要它。

为了解决这个问题,在项目的根目录下打开build.gradle文件,把gradle版本改成0.9。+。

 buildscript { repositories { mavenCentral() } dependencies { classpath 'com.android.tools.build:gradle:0.9.+' } } 

为每个项目重复;(

如果您接着收到类似“ 无法加载类org.gradle.api.artifacts.result.ResolvedComponentResult ”的消息。

转到您的project_folder/gradle/wrapper目录并编辑Unable to load class 'org.gradle.api.artifacts.result.ResolvedComponentResult'. 文件改变distributionUrl

 distributionUrl=http\://services.gradle.org/distributions/gradle-1.10-all.zip 

升级到版本0.8.1(完整下载并复制SDK文件夹)后,必须安装由IDE安装的新版gradle(使用“Fix it”链接几次:S),并修改“android”部分如下所示:buildscript {repositories {mavenCentral()} dependencies {classpath'com.android.tools.build:gradle:0.12.+'}} apply plugin:'android'

 repositories { mavenCentral() } android { compileSdkVersion 19 buildToolsVersion '19.1.0' defaultConfig { minSdkVersion 7 targetSdkVersion 19 } } dependencies { compile 'com.android.support:appcompat-v7:19.1.+' compile 'com.android.support:support-v4:19.1.0' } 

我有同样的错误,但已经有了

 classpath 'com.android.tools.build:gradle:0.9.+' 

就像塞德里克·西蒙(Cedric Simon)所build议的那样。 由于mattblang的评论,我试图将其更改为0.9.0并刷新它

对于那些不知道刷新button的地方,请看下面:

在这里输入图像说明

之后,我尝试了将它更改回0.9,并再次刷新时发生了什么……并且仍然有效。

所以我想,只有按下刷新button才行。

我面临同样的问题迁移到gradle版本1.0.0 ..这个解决scheme帮助我,并保存date..

更新插件和Gradle版本号

Android Gradle插件版本通常在项目的顶层build.gradle文件中列出,并且可以更新如下:

让我考虑我有版本0.8 ..显示我的build.gradle(项目根文件夹/ build.gradle)显示

依赖关系{classpath'com.android.tools.build:gradle:0.8.+'}

删除旧版本(0.8),并像这样添加新的版本1.0.0

依赖关系{classpath'com.android.tools.build:gradle:1.0.0'}

还要改变gradle / wrapper / gradle-wrapper.properties

删除旧的distributionUrl并添加新的url

distributionUrl = HTTP://services.gradle.org/distributions/gradle-2.2.1-all.zip

并在项目root / app / build.gradle中更改runProguard

之前:

buildTypes {release {runProguard true proguardFiles getDefaultProguardFile('proguard-android.txt'),'proguard-rules.pro'}}

后:

buildTypes {release {minifyEnabled true proguardFiles getDefaultProguardFile('proguard-android.txt'),'proguard-rules.pro'}}

欲了解更多信息: 迁移gradle项目(点击这里)

最简单的Android项目有以下build.gradle:

 buildscript { repositories { mavenCentral() } dependencies { classpath 'com.android.tools.build:gradle:0.9.0' } } apply plugin: 'android' android { compileSdkVersion 19 buildToolsVersion "19.0.0" } 

这个Android构build文件有三个主要的区域:

新build系统用户指南

当我更新到Android Studio 1.0时,我发现我需要更新以使用1.0.0版本的gradle。

我有

  dependencies { classpath 'com.android.tools.build:gradle:1.0.0-rc2' 

我改变它去除“-rc2”

  dependencies { classpath 'com.android.tools.build:gradle:1.0.0' 

Android Studio版本1.0.2 IDE版本和构build版本之间紧密耦合的想法是不好的。

Android Studio 1.0.2。 Gralde插件1.0。+ gradle.properties,分发URL = http://services.gradle.org/distributions/gradle-2.2.1-bin.zip

嗯,我收到这个错误,当我尝试添加此依赖项。

错误:(22)评估项目“:app”时发生问题。

无法在项目':app'上find参数[com.android.tools.build:gradle:0.9.+]的方法classpath()。

好的解决了它。 如上所述,这一行应该是“项目根目录”中的build.gradle的一部分,但我没有认识到。 更新Build工具到19.03实际上自动插入它。