运行Android Studio IDE时出错

当我启动Android工作室时遇到这个错误:

在这里输入图像说明

The following SDK components were not installed: build-tools-21.1.1, source-21, sys-img-x86-addon-google_apis-google-21, extra-android-m2repository, android-21, extra-google-m2repository, addon-google_apis-google-21, tools, platform-tools 

而当我点击重试,它给了我同样的错误:

在这里输入图像说明

Solutions Collecting From Web of "运行Android Studio IDE时出错"

configurationandorid studio的代理。 这里:

C:\ Users \“Your account”.AndroidStudio \ config \ options \ other.xml

然后改变代理configuration这一行:

 <option name="USE_HTTP_PROXY" value="true" /> <option name="USE_PROXY_PAC" value="false" /> <option name="PROXY_HOST" value="your proxy server" /> <option name="PROXY_PORT" value="your proxy port" /> 

code.google.com/p/android/issues/detail?id=82789

  1. 下载build-tools21.1.1 谷歌链接或dehkadeco.ir链接

  2. sdk将位于C:\ Users \ <> \ AppData \ Local \ Android \ sdk下。

  3. 您可能会发现21.1.2已经到位了C:\ Users \ <> \ AppData \ Local \ Android \ sdk \ build-tools在此下创build名为“21.1.1”的文件夹。

  4. 将下载的build-tools中的所有文件复制到android:5.0下的C:\ Users \ <> \ AppData \ Local \ Android \ sdk \ build-tools \ 21.1.1

  5. 现在开始安卓工作室。

尝试重命名文件夹内的Android SDK build-tools文件夹(在我的情况下,这是c:\Users\prokofyev\AppData\Local\Android\sdk\build-tools\21.1.2 )到android-5.0 (在我它变成了c:\Users\prokofyev\AppData\Local\Android\sdk\build-tools\android-5.0 )。 这样我修复了新的Android Studio安装类似的错误。

由于Intranet代理/防火墙设置,Android Studio无法连接到我的工作电脑中的互联网,更改代理设置也帮不了我。

Android工作室无法运行,因为它需要安装上述软件包。 作为解决scheme,我从Android SDK Manager安装了软件包,并解决了这个问题。

您可以在C:\ Users \ <用户名> \ AppData \ Local \ Android \ sdk \ SDK Manager.exe下findSDKpipe理器。在GUI中,select以下选项中的任何一个。

  • 工具 – >版本21下的所有Android SDK构build工具和SDK平台工具。*
  • 在Android 5.0.1(API 21)下的所有东西
  • 一切在附加

安装完成后,请尝试启动Android Studio

添加回答@Erfan,如果您使用的是自动configuration脚本而不是代理服务器,请按如下方式更改设置:

C:\ Users \“Your account”.AndroidStudio \ config \ options \ other.xml

然后改变代理configuration这一行:

 <component name="HttpConfigurable"> <option name="PROXY_TYPE_IS_SOCKS" value="false" /> <option name="USE_HTTP_PROXY" value="false" /> <option name="USE_PROXY_PAC" value="true" /> <option name="PROXY_HOST" value="" /> <option name="PROXY_PORT" value="80" /> <option name="PROXY_AUTHENTICATION" value="true" /> <option name="PROXY_LOGIN" value=" your User Name" /> <option name="PROXY_PASSWORD_CRYPT" value=" Your Domain Password " /> <option name="KEEP_PROXY_PASSWORD" value="false" /> <option name="myGenericPasswords"> <map /> </option> <option name="myGenericCancelled"> <set /> </option> <option name="PROXY_EXCEPTIONS" value="" /> <option name="USE_PAC_URL" value="true" /> <option name="PAC_URL" value=" Put Pac Url Here mentioned in Auto Config Script " /> </component> 

我有同样的问题,但是当我打开工作室“以pipe理员”的错误已经走了!!! 我的问题解决了! 在我的情况下,我已经在不同的位置安装了SDK,因为我不想在我的用户文件夹上安装任何东西。

在这里输入图像说明

还有一件事是我做了这个文件夹可读的访问权限。 (但我不认为这一步是必要的)

这通常发生在你无法从谷歌下载sdk时,尝试手动下载。

你可以得到你在谷歌或贝洛链接提到的构build:

这个链接

解压缩到\ sdk \ build-tools中

一些工具丢失。

下载build-tools_r21.1.1-windows.zip并解压缩。 再次运行Android Studio。

如果你再次得到类似的错误检查这个失踪的Android工具。

享受编码.. 🙂

对于Ubuntu用户,请检查安装SDK的文件夹是否具有权限。

我也有同样的问题。 看到下面的图片:

在这里输入图像说明

解决scheme:以pipe理员身份运行。

在这里输入图像说明

如果你得到UnknownHostException的问题在于代理 – 点击closures图标(右上angular的X),并同意再次开始安装。 然后在Studio本身去configuration – >设置 – >search代理并设置您的代理(自动检测或手动)。

以pipe理员身份运行也可能有帮助

从build-tools_r21.1.1-windows.zip下载build-tools:21.1.1

并解压,它会提取整个文件夹来复制或移动你的SDK / build-tools文件夹。 名称文件夹必须是build-tools_21.1.1