Android Studio错误:(8,0)未findid为'android'的插件

我已经使用Brew(brew安装gradle)在OS X(10.9.3)和Gradle 1.1上安装了Android Studio(0.6.1)。 不过,我无法得到我的第一个Hello World! 项目…请帮我解决这个问题

的build.gradle:

buildscript { repositories { mavenCentral() } dependencies { classpath 'com.android.tools.build:gradle:0.11.+' } } apply plugin: 'android' repositories { mavenCentral() } android { compileSdkVersion 19 buildToolsVersion '19.1' defaultConfig {} productFlavors {} } dependencies { } 

错误信息:

错误:(8,0)找不到id为'android'的插件。

获取生成失败,Android Studio 0.4.3和0.4.4发布和Android Studio:插件ID为'android-library'未find的post不能解决问题…

我链接的第二篇文章返回这个错误信息:

错误:项目正在使用不支持的Gradle版本。 请使用版本1.10。 请在项目的Gradle设置或项目的Gradle包装(如果适用)中指向受支持的Gradle版本。修复Gradle包装并重新导入项目Gradle设置

Solutions Collecting From Web of "Android Studio错误:(8,0)未findid为'android'的插件"

看来你错过了在dependencies块中添加android gradle插件依赖。

用这个replace顶部的buildScript部分,并用gradle同步你的项目

  buildscript { repositories { mavenCentral() } dependencies { classpath 'com.android.tools.build:gradle:0.11.+' } } apply plugin: 'android' android { compileSdkVersion 19 buildToolsVersion '19.1.0' defaultConfig { applicationId 'YOUR_APP_PACKAGE' minSdkVersion 9 targetSdkVersion 17 } buildTypes { release { runProguard false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt' } } productFlavors { } } dependencies { } 

在我的“应用程序”文件夹build.gradle文件:PATH:/home/work/ProjectName/app/build.gradle

 android { compileSdkVersion 19 buildToolsVersion '19.1.0' defaultConfig { minSdkVersion 11 targetSdkVersion 19 versionCode 1 versionName '1.0' } dependencies { compile 'com.android.support:support-v4:18.0.0' compile 'com.android.support:appcompat-v7:+' } } 

我的“应用程序”文件夹外build.gradle文件:PATH:/home/work/ProjectName/build.gradle

 buildscript { repositories { mavenCentral() } dependencies { classpath 'com.android.tools.build:gradle:0.11.+' } } allprojects { repositories { mavenCentral() } } 

所有这些更新之后请注意同步您的项目与gradle文件

将以下代码放在主应用程序的build.gradle文件中并同步它。

 buildscript { repositories { mavenCentral() } dependencies { classpath 'com.android.tools.build:gradle:1.0.0' } } allprojects { repositories { mavenCentral() } } 

感谢Ganesh Katikar