Android Studio无法parsing存储库

在我的项目中,我试图使用devise支持库。 我在我的Gradle文件中:

dependencies { .... compile 'com.android.support:design' .... } 

而当我试图build立这个,我得到的错误:

在这里输入图像说明

通常我只要点击Install Repository and sync project ,但是,这似乎不工作了 。 点击这个没有任何作用,即使点击Open File正常工作。

我如何手动安装它?

我安装了最新的Android支持库(30.0.0)和Android支持库(23.2.1)。

我想这是因为你没有指定版本。

 compile 'com.android.support:design:23.1.1' 

将版本更改为您下载的版本。

对我来说,解决的办法是在allprojects部分添加maven。 从设置文档: https : //developer.android.com/topic/libraries/support-library/setup.html

在项目级别settings.gradle文件中。

 allprojects { repositories { jcenter() maven{ url "https://maven.google.com" } } } 

然后再次检查文件的最新版本。 在settings.gradle文件的应用程序级别添加:

 dependencies{ compile 'com.android.support:design:26.0.1' } 

并使用Gradle同步项目。

你可以去文件 – >设置 – > Gradle看看“离线工作”收件箱,

如果选中,您可以取消选中并尝试再次同步。