Android Studiovector资产导入错误 – 不支持的标签

我已经用新的gradle插件 – 1.4.0-beta3testing了Andorid Studio。

我一直在试图导入我自己的vector资产,Inkscape。 但是我不断收到导入错误。 错误消息包含许多不支持的svg标签。

In mm_card.svg: ERROR@ line 54 <defs> is not supported ERROR@ line 56 <linearGradient> is not supported ERROR@ line 58 <stop> is not supported ERROR@ line 62 <stop> is not supported ERROR@ line 66 <stop> is not supported ERROR@ line 70 <stop> is not supported ERROR@ line 74 <stop> is not supported ERROR@ line 78 <stop> is not supported ERROR@ line 83 <linearGradient> is not supported ERROR@ line 85 <stop> is not supported ERROR@ line 89 <stop> is not supported ERROR@ line 93 <stop> is not supported ERROR@ line 97 <stop> is not supported ERROR@ line 102 <linearGradient> is not supported ERROR@ line 104 <stop> is not supported ERROR@ line 108 <stop> is not supported ERROR@ line 113 <linearGradient> is not supported ERROR@ line 115 <stop> is not supported ERROR@ line 119 <stop> is not supported ERROR@ line 123 <stop> is not supported ERROR@ line 127 <stop> is not supported ERROR@ line 131 <stop> is not supported ERROR@ line 135 <stop> is not supported ERROR@ line 139 <stop> is not supported 

有谁知道这个的原因? 这是vector资产工具的错误吗? 或者也许由Inkscape创build的svgs问题? 还是更复杂的SVG不支持?

谢谢!

Related of "Android Studiovector资产导入错误 – 不支持的标签"

Android Studio中的SVG导入function对于某些SVGfunction的支持有限。

他们在公告video中陈述的很多。 他们说他们打算改进import商。

但是也要注意VectorDrawables不支持渐变。