无法访问android.support.v4.app.BaseFragmentActivityHoneycomb

我使用support.v7.app.AppcompatActivity实现了一个Android应用程序。 这个应用程序不能编译:当我把鼠标光标放在super键上时,它显示以下错误:

 Cannot access android.support.v4.app.BaseFragmentActivityHoneycomb 

Android Studio截图

Solutions Collecting From Web of "无法访问android.support.v4.app.BaseFragmentActivityHoneycomb"

我有同样的问题。 我的决议是:

replace项目依赖关系:

 dependencies { compile fileTree(include: ['*.jar'], dir: 'libs') testCompile 'junit:junit:4.12' compile 'com.android.support:appcompat-v7:23.3.0' compile 'com.android.support:design:23.3.0' 

}

 dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) testCompile 'junit:junit:4.12' compile 'com.android.support:appcompat-v7:24.0.0' compile 'com.android.support:support-annotations:24.0.0' 

}

它适合我,祝你好运。

导入android支持库v4可以解决这个问题