Articles of 插件

ADB无法启动以确保插件配置正确

我时不时地遇到这个问题,它说“ ADB服务器没有确认,无法启动守护进程 ”。 首先,我按照一些说明重置了DDMS中的adb,然后它给了我“ adb无法启动,确保插件配置正确 ”。 在阅读了其他一些解决方案之后,我在我的任务管理器中杀死了adb.exe,但是在2秒后它又恢复了活力。 我已经重启了我的日食和电脑几次,仍然没有运气。 有谁知道这个问题是什么? 我正在使用win8,不知道是不是问题…

由于依赖于bundle org.eclipse.core.runtime 3.8.0,无法在eclipse中安装插件

我在为eclipse安装Genymotion插件时遇到连续失败的安装问题。 错误日志显示“ 它需要bundle org.eclipse.core.runtime 3.8.0 ”。 错误日志: Cannot complete the install because one or more required items could not be found. Software being installed: Genymotion Eclipse Tools 1.0.1.201307161043 (com.genymobile.genymotion.ide.eclipse.feature.group 1.0.1.201307161043) Missing requirement: Genymotion 1.0.1.201307161043 (com.genymobile.genymotion.ide.eclipse.plugin 1.0.1.201307161043) requires ‘bundle org.eclipse.core.runtime 3.8.0’ but it could not be found Cannot satisfy dependency: From: Genymotion Eclipse Tools 1.0.1.201307161043 (com.genymobile.genymotion.ide.eclipse.feature.group […]

Phonegap原生android插件

我尝试在phonegap / cordova 3.0.0上运行我的原生android插件,但我不工作, 来自ripple的错误:Uncaught ReferenceError:未定义torch 来自index.html的调用 dummy plugin.xml 插件的www文件夹中的torch.js var exec = require(‘cordova/exec’); /* constructor */ function Torch() {} Torch.shine = function() { exec( function(result){ alert(‘ok: ‘+reply); }, function(err){ alert(‘Error: ‘+err); } , “Torch”, “shine”, [‘200’]); } var torch = new Torch(); module.exports = torch; 和Torch.java /* */ package org.holzi.torch; import org.apache.cordova.CallbackContext; import org.apache.cordova.CordovaPlugin; […]

Jenkins上的Android模拟器错误:设备离线

我已经为Jenkins安装了Android Emulator插件。 我可以构建和测试Android项目。 我的Jenkins运行在Ubuntu服务器上(仅限终端访问)。 该项目是从Github撤出的。 现在我想使用模拟器。 这是我的配置: Android操作系统版本:4.4 屏幕密度:160 屏幕分辨率:480×800 目标ABI:armeabi-v7a 我还安装了adb并执行了以下命令: /opt/android-sdk-linux/tools/android update sdk –no-ui 但它不起作用: > /usr/bin/git rev-list 3440b28279e2e95113ce1c9499d9d881e76f6810 # timeout=10 $ /opt/android-sdk-linux/tools/android list target [android] Using Android SDK: /opt/android-sdk-linux $ /opt/android-sdk-linux/platform-tools/adb start-server * daemon not running. starting it now on port 7767 * * daemon started successfully * $ /opt/android-sdk-linux/platform-tools/adb start-server [android] […]

Eclipse连接到存储库并在Windows 8上安装ADT插件时出错

我最近更新到Windows 8(不要问为什么因为它变得比它更值得麻烦!) 从那以后,我的Eclipse和ADT插件停止工作。 所以我再次下载了Eclipse Classic并尝试下载ADT插件而没有运气。 (注意:选中时,Eclipse下拉菜单中没有下载菜单) 尝试连接到在线存储库时,我不断收到以下错误消息:无法通过https://dl-ssl.google.com/android/eclipse/site.xml/content.xml读取存储库。 无法通过https://dl-ssl.google.com/android/eclipse/site.xml/content.xml读取存储库。 无法分配请求的地址:connect 当试图通过ZIP文件添加插件时,我遇到了以下错误:无法完成安装,因为无法find一个或多个必需的项目。 正在安装的软件:Android开发工具20.0.3.v201208082019-427395(com.android.ide.eclipse.adt.feature.group 20.0.3.v201208082019-427395) 坚持并需要一些建议! 我有最新版本的Android SDK,并已更新到最新版本的Java Run-time和JDK

phonegap 3.3.0中的本地通知

谢谢道森! 下面提到的问题已在android中解决。 但遗憾的是,当我在ios中构建项目时它不起作用,任何人都可以帮忙吗? 我打算使用这个插件来构建一个带有本地通知的android / ios应用程序。 https://github.com/katzer/cordova-plugin-local-notifications/wiki 首先,我创建了一个phonegap项目 phonegap create notification 添加插件 cordova plugin add https://github.com/katzer/cordova-plugin-local-notifications.git 修改/www/config.xml 我将local-notification.js复制到/ www目录并在index.html中引用它 Hello World PhoneGap Connecting to Device Device is Ready ] window.plugin.notification.local.add({ message: ‘Great app!’ }); 我使用命令构建了android应用程序 phonegap build android 我可以成功构建Android应用程序,但没有按预期加快通知。 在上面的介绍中,有谁能知道我的错吗? 非常感谢你们所有人。

如何使用phonegap插件中的Plugin.xml文件在清单文件中添加android:largeHeap =“true”

我们如何使用android phonegap中的plugin.xml文件在清单文件中添加android:largeHeap为true

如何更新Android Studio Beta频道

我正在使用Android Studio,当我尝试更新它时,请向我显示以下内容 我如何更新它,并尝试使用选项Help-> checkForUdates但它显示相同。

如何让Android应用程序像这样漂亮?

我是一个业余的android程序员,我真的很喜欢编码。 我的主要困难是使应用程序变得更好。 我遇到了一个简单的应用程序,但与此同时,很好: https : //play.google.com/store/apps/details?id = com.linksaude.bulas 我想知道这个应用程序是否已经为Eclipse或其他任何特定的插件/插件设计。 它似乎是如此一致和精美的设计,必须有一个答案,以简化此类应用程序的构建过程。 谢谢!

Android应用内购买插件?

我正在开发一款需要插件的Android应用。 这些插件本质上是我的应用程序使用的资产包。 我可能最初会创建大部分这些资产包插件,但我希望其他开发人员能够为我的应用创建(和销售)这些资产包。 如果需要,可以将这些资产插件视为Minecraft的纹理包。 这些资产包每个大约50 MB,因此将它们与应用程序打包是没有意义的。 我想要这样做的方式: 开发人员创建名为特定内容的插件资产APK(org.name.app_name.plugin。{MY_ASSET_PACK}) 开发者申请自己的Google Play开发者帐户,并在“库和演示”部分中以自己的名义列出资产包(免费或付费)。 我的应用程序向Google Play查询与查询字符串 (org.name.app_name.plugin。*) 匹配的所有apk包(免费或付费), 并将其列在应用程序用户的“过滤市场视图”中,允许他们使用轻松find应用程序的插件。 用户可以在我的“过滤市场视图”中点击这些条目,然后直接重定向到Google Play市场并通过Play进行购买,开发人员可以通过此交易获得补偿。 购买的资产插件apk被下载到用户的设备,并且不会显示在启动器中。 (请参阅如何发布应用程序插件 ) 我的应用程序索引手机上与查询字符串(org.name.app_name.plugin。*)匹配的包,并将它们放在“插件选择器视图”中供用户选择。 我的应用程序加载并使用此插件中的资源(请参阅如何发布应用程序插件 ) 问题 问题存在于步骤4.我找不到任何方法从我的应用程序内查询商店(即使没有通配符)。 我确实find了这个“android-market-api”项目,它允许我从我的应用程序中查询市场,但它似乎需要一个Google Services用户名和密码,我必须从用户查询。 这是一个非首发。 问题 有没有一种简单的方法可以解决这个问题并直接在我的应用程序中的列表中获取市场查询? 这是处理应用程序插件的错误方法吗? 有没有办法使用现有的应用程序内购买API来处理这个问题,而无需为这些软件包维护我自己的服务器?