Articles of 机器人工作室

Android Studio未加载

在Google宣布基于IntelliJ的Android Studio之后,我想尝试一下,但我遇到了问题。 它安装得很好,并且在安装过程中成功find了JDK,但是当我尝试启动它时没有任何反应。 没有错误,没有闪屏没有什么。 其他人遇到过这个问题吗? 感谢您的任何帮助,您可以提供。

在Android Studio中禁用虚拟设备管理器

我在Windows 7 PC上安装了Android Studio。 但我无法在工作室上创建虚拟设备,因为默认情况下禁用AVD和SDK按钮。 我如何启用它们?

如何使用root phonegap www文件夹?

当您创建一个phonegap项目时,您可以从根www文件夹开始,以及其他文件。 /www 然后,您需要添加设备才能工作,例如andriod或IOS。 然后,在相应的playforms中创建一个新的www文件夹: \platforms\android\assets\www 我的问题是,当使用Android Studio时,您打算如何使用根www文件夹? 如果有的话? 我打算用哪个www文件夹构建? 看来,在使用Android Studio导入时直接进入平台/ andriod。

在string.xml文件中不存在Android Studio字符串hello_world

我是Android应用程序开发的新手,试图关注这个主题的介绍书。 创建一个空白项目后,我被指示打开string.xml文件,该文件应该包含元素Hello World! ,以便编辑TextView的默认文本目的。 但是,该文件不包含此元素。 它只包含: 此外,本书仅显示activity_main.xml布局文件,而我看到了activity_main.xml和content_main.xml文件。 也许这是一个版本问题? 我安装的Android SDK在Windows 10上安装了最新的API 23,而我认为这本书是在API 23发布之前发布的。

将Android Studio升级到2.0后,Android Emulator无法在Ubuntu上运行 – 找不到Qt库

今天,我将Android Studio安装升级到2.0版。 我手动更新了它(下载.zip,因为更新机制只是告诉我有一个新版本但没有提供在Android Studio中直接更新的可能性)。 当我现在尝试启动模拟器时,我收到此错误消息: 错误:./ android / qt / qt_setup.cpp:33:在/ home / kcd / Android / Sdk / tools / lib / qt / lib找不到Qt库无法启动’/ home / kcd / Android / Sdk / tools / qemu / linux-x86 / qemu-system-x86_64’:没有这样的文件或目录 我检查了这个目录并注意到路径名是… / qemu / linux-x86_64 / qemu-system_x86_64而不是… / qemu / linux-x86 / qemu-system_x86_64 所以我重命名了direcory以匹配正确的路径。 […]

android studio中的多个目标

我正在处理一个教育大学的项目,那里有5所独立大学, 每所大学都有自己的应用程序,但在每个应用程序图像中,json不同, 源代码保持不变。 我想使用一个源代码创建具有不同包名称的5个独立apks,如果源代码中的任何更改应该在所有apks中更新。 请给我项目的结构,graddle.build工具设置,如果我需要使库如何以及它将在哪里,或者请上传样本以做详细的上述types。

发现无法将android studio 2.0更新为2.1

我一直在尝试从2.0更新android studio到2.1并且已经没有想法了。 我得到了一个 java.lang.OutOfMemoryError: Java heap space 错误。 我已经尝试过寻找解决方案并尝试过这样的解决方案而没有任何乐趣: StackOverFlow答案 来自Google的Tech-Docs 这是我收到的完整错误: Temp. directory: C:\Users\Aaron\AppData\Local\Temp\ java.lang.OutOfMemoryError: Java heap space at java.util.Arrays.copyOf(Arrays.java:3236) at java.io.ByteArrayOutputStream.grow(ByteArrayOutputStream.java:118) at java.io.ByteArrayOutputStream.ensureCapacity(ByteArrayOutputStream.java:93) at java.io.ByteArrayOutputStream.write(ByteArrayOutputStream.java:153) at com.intellij.updater.Utils.copyStream(Utils.java:165) at ie.wombat.jbdiff.JBPatch.bspatch(JBPatch.java:83) at com.intellij.updater.BaseUpdateAction.applyDiff(BaseUpdateAction.java:112) at com.intellij.updater.UpdateAction.doApply(UpdateAction.java:44) at com.intellij.updater.PatchAction.apply(PatchAction.java:184) at com.intellij.updater.Patch$3.forEach(Patch.java:308) at com.intellij.updater.Patch.forEach(Patch.java:360) at com.intellij.updater.Patch.apply(Patch.java:303) at com.intellij.updater.PatchFileCreator.apply(PatchFileCreator.java:84) at com.intellij.updater.PatchFileCreator.apply(PatchFileCreator.java:75) at com.intellij.updater.Runner.doInstall(Runner.java:280) at com.intellij.updater.Runner.access$000(Runner.java:17) at com.intellij.updater.Runner$1.execute(Runner.java:246) at com.intellij.updater.SwingUpdaterUI$5.run(SwingUpdaterUI.java:191) […]

“无法在Android Studio中获取文件的编译器信息…”

我在Android Studio中遇到了这个非常奇怪的错误消息。 它显示在我使用ndk-build通过Gradle ndk-build 本机代码之上。 断点和代码步进正常工作,但代码中充斥着“无法解决variables”之类的“错误”。 以下是它的外观示例: 同样,代码都运行正常,就像IDE似乎无法解析一大堆types。 您可以在右侧看到一连串的错误。 基本上每一行都被标记为错误,即使它们都编译得很好。 不知道发生了什么!

如何修改Android 9patch图像的颜色?

我真的不明白如何创建一个9patch图像,但我find了一个正在处理我片段的图像。 问题是边框外的颜色不是背景的颜色。 我尝试将像素的颜色从图像更改为背景的颜色,但生成的图像不再起作用。 这是正在工作但颜色错误的图像: http://img.androidcookie.com/android/cJBfV.png 如何更改边框外像素的颜色,或者如何创建看起来像这样的新9patch图像?

添加Google Analytics后无法生成APK,但在调试模式下正常运行

这是一个非常奇怪的情况。 我可以构建我的项目,清理和构建我的项目,甚至可以在具有调试模式的物理设备上运行。 我还获得了Google Analytics网页上所需的所有数据。 可悲的是,Android Studio没有生成发行版,.apk文件。 我完全按照向您的Android应用程序添加分析 , 官方教程 ,并搜索了许多答案,但确切的问题仍然存在。 我的build.gradle看起来像这样: apply plugin: ‘com.android.application’ apply plugin: ‘com.google.gms.google-services’ android { compileSdkVersion 23 buildToolsVersion “23.0.0” defaultConfig { applicationId “com.comname.appname” minSdkVersion 11 targetSdkVersion 23 versionCode 18 versionName “2.7” } buildTypes { release { minifyEnabled true zipAlignEnabled true proguardFiles getDefaultProguardFile(‘proguard-android.txt’), ‘proguard-rules.pro’ } } } dependencies { compile fileTree(include: [‘*.jar’], […]