Articles of 机器人工作室

在updatng Android Studio之后奇怪的错误

所以离开我的Android Studio项目一段时间后,我跑了所有的更新。 我的构buildgradle定义了这一点 compileSdkVersion 23 buildToolsVersion '23.0.1' 但是,现在当我重build所有我得到的错误: W:\ android-studio-projects \ sharedid \ app \ build \ intermediates \ res \ merged \ debug \ values -v24 \ values -v24.xml错误:(3)检索父项的错误:找不到与给定的资源名称“android:TextAppearance.Material.Widget.Button.Borderless.Colored”。 错误:(4)检索项目的父项时出错:未find与给定名称“android:TextAppearance.Material.Widget.Button.Colored”匹配的资源。 错误:(3)检索项目的父项时出错:找不到与给定名称'android:TextAppearance.Material.Widget.Button.Borderless.Colored'匹配的资源。 错误:(4)检索项目的父项时出错:未find与给定名称“android:TextAppearance.Material.Widget.Button.Colored”匹配的资源。 这里是文件 – 我没有创build一个: <?xml version="1.0" encoding="utf-8"?> <resources> <style name="Base.TextAppearance.AppCompat.Widget.Button.Borderless.Colored" parent="android:TextAppearance.Material.Widget.Button.Borderless.Colored"/> <style name="Base.TextAppearance.AppCompat.Widget.Button.Colored" parent="android:TextAppearance.Material.Widget.Button.Colored"/> <style name="TextAppearance.AppCompat.Notification.Info.Media"/> <style name="TextAppearance.AppCompat.Notification.Media"/> <style name="TextAppearance.AppCompat.Notification.Time.Media"/> <style name="TextAppearance.AppCompat.Notification.Title.Media"/> </resources> […]

NoClassDefFoundError android / support / v4 / animation / AnimatorCompatHelper

更新Android Studio到2.3.1和gradle到3.3后,我注意到应用程序正在崩溃的某个活动。 更新之前,一切都很好。 我已经浪费了一天这个东西,我真的似乎无法弄清楚为什么我得到一个'java.lang.NoClassDefFoundError:失败的解决scheme:Landroid / support / v4 / animation / AnimatorCompatHelper;' 致命的例外。 我也会上传build.gradle文件中最重要的部分 apply plugin: 'com.android.application' android { compileSdkVersion 23 buildToolsVersion ANDROID_BUILD_TOOLS defaultConfig { minSdkVersion 16 targetSdkVersion ANDROID_TARGET_SDK } signingConfigs { release { …. } } buildTypes { release { … } debug { .. } } sourceSets.main { .. } flavorDimensions "abi", "countMode" […]

在Android Studio布局devise预览中select目标API

我的应用程序的目标是API 17,但最小Sdk版本是8.在布局devise预览页面,我可以说我的布局是如何出现在API 17版本,但是如果我点击APIselect器下拉菜单,我不能select任何其他API级别。 据我所知,我可以在2.3 Android版本和真实设备上运行我的应用程序,我可以看到结果,但在devise预览页面中是否有testing的方法? 我的清单片段: <uses-sdk android:minSdkVersion="8" android:targetSdkVersion="17" />

我怎样才能导入一个新的模块(Android库项目)使用Android Studio 0.3.0

android工具团队在介绍android studio 0.3.0时,用了新的用户界面,使用项目结构来修改build.grade文件,这是一个巨大的步骤。 但是,我怎样才能将一个Android库项目导入到我的一般项目中? 当我按下Project结构 – >模块部分中的'+'button时,我只能创buildNEW模块。

首先用AndroidStudio构build失败

我是新来的android编程,我想用Android Studio的开始。 我在我的Ubuntu 14.04机器上下载并安装了AndroidStudio 0.8.0。 我也正确地设置了java。 当我创build一个新的项目(如http://developer.android.com/training/basics/firstapp/creating-project.html所述 ),它看起来会尝试构build示例文件。 但是,我总是得到这个错误: /home/daniel/AndroidStudioProjects/Heimweg/app/src/main/res/drawable-xhdpi/ic_launcher.png Error:Error: Cannot run program "/home/daniel/android/android-studio/sdk/build-tools/android-4.4W/aapt": error=2, No such file or directory Error:Execution failed for task ':app:mergeDebugResources'. /home/daniel/AndroidStudioProjects/Heimweg/app/src/main/res/drawable-xhdpi/ic_launcher.png:Error:Can not run program“/ home / daniel / android / android-studio / sdk / build-tools / android- 4.4W / aapt“:error = 2,没有这样的文件或目录 我该如何处理这个错误? 当我尝试运行应用程序,它说»亚行没有回应。 您可以等待更多,或手动杀死“adb”进程,然后单击“重新启动”

Android Studio错误:(8,0)未findid为'android'的插件

我已经使用Brew(brew安装gradle)在OS X(10.9.3)和Gradle 1.1上安装了Android Studio(0.6.1)。 不过,我无法得到我的第一个Hello World! 项目…请帮我解决这个问题 的build.gradle: buildscript { repositories { mavenCentral() } dependencies { classpath 'com.android.tools.build:gradle:0.11.+' } } apply plugin: 'android' repositories { mavenCentral() } android { compileSdkVersion 19 buildToolsVersion '19.1' defaultConfig {} productFlavors {} } dependencies { } 错误信息: 错误:(8,0)找不到id为'android'的插件。 获取生成失败,Android Studio 0.4.3和0.4.4发布和Android Studio:插件ID为'android-library'未find的post不能解决问题… 我链接的第二篇文章返回这个错误信息: 错误:项目正在使用不支持的Gradle版本。 请使用版本1.10。 请在项目的Gradle设置或项目的Gradle包装(如果适用)中指向受支持的Gradle版本。修复Gradle包装并重新导入项目Gradle设置

在新的CardView中alignment多个TextView

我试图创build一个CardView,显示一个作者的报价,包括作者姓名,报价,然后是下面的参考。 我想我已经得到了大部分,但似乎alignmentTextViews的一般规则似乎并不适用于CardView。 我在这里进行了研究,发现你应该将android:layout="vertical"到LinearLayout(或者RelativeLayout),但是这对我来说似乎没有什么改变。 我也尝试将它添加到CardView本身,认为它inheritance了父母的方向,但也没有运气。 我仍然得到TextViews相互重叠,而不是一个接一个。 <LinearLayout xmlns:android="http://schemas.android.com/apk/res/android" xmlns:tools="http://schemas.android.com/tools" xmlns:card_view="http://schemas.android.com/apk/res-auto" android:layout_height="match_parent" android:layout_width="match_parent"> … > <!– A CardView that contains a TextView –> <android.support.v7.widget.CardView xmlns:card_view="http://schemas.android.com/apk/res-auto" android:id="@+id/card_view" android:layout_gravity="top" android:layout_width="match_parent" android:layout_height="wrap_content" android:longClickable="true" android:orientation="vertical" card_view:cardUseCompatPadding="true" card_view:cardCornerRadius="4dp" card_view:cardElevation="4dp" card_view:contentPadding="10dp" > <TextView android:id="@+id/info_text" android:layout_width="fill_parent" android:layout_height="wrap_content" android:textColor="#FF4444" android:textSize="24sp" android:text="Gordon B. Hinckley" /> <TextView android:id="@+id/info_text2" android:layout_width="wrap_content" android:layout_height="wrap_content" android:layout_below="@+id/info_text" android:text="Test text. Test text. Test text. […]

android.test.AndroidTestCase中的方法setUp没有被模拟

我正在尝试使用Android Studio的新unit testingfunction。 我遵循http://tools.android.com/tech-docs/unit-testing-support上的说明。 其中的描述明确提到了“Method … not mocked”错误,并build议将以下内容放入build.gradle : android { // … testOptions { unitTests.returnDefaultValues = true } } 只要从命令行开始运行testing,就可以工作 gradlew test –continue 但不是当我从Android Studio运行testing类与右键单击 – >运行。 这样,我再次得到相同的错误: java.lang.RuntimeException: Method setUp in android.test.AndroidTestCase not mocked. See https://sites.google.com/a/android.com/tools/tech-docs/unit-testing-support for details. at android.test.AndroidTestCase.setUp(AndroidTestCase.java) at org.junit.internal.runners.JUnit38ClassRunner.run(JUnit38ClassRunner.java:86) at org.junit.runner.JUnitCore.run(JUnitCore.java:137) at com.intellij.junit4.JUnit4IdeaTestRunner.startRunnerWithArgs(JUnit4IdeaTestRunner.java:74) at com.intellij.rt.execution.junit.JUnitStarter.prepareStreamsAndStart(JUnitStarter.java:211) at com.intellij.rt.execution.junit.JUnitStarter.main(JUnitStarter.java:67) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) […]

Gradle同步失败:原因:打开zip文件Corrupt Dependency Cache时出错

嘿,伙计们,我是Android Studio的新手,刚开始学习Udacity这个在线课程“开发Android应用程序”。问题是我正在开发的项目保持与“ Sunshine ”课程一致,没有正确同步。 .. 这是事件日志中显示的消息。 Gradle同步失败:原因:打开zip文件时出错 日志的完整描述: **2017-03-04 08:14:32,358 [ 61978] WARN – nal.AbstractExternalSystemTask – Cause: error in opening zip file com.intellij.openapi.externalSystem.model.ExternalSystemException: Cause: **error in opening zip file** at com.android.tools.idea.gradle.project.sync.idea.ProjectImportErrorHandler.getUserFriendlyError(ProjectImportErrorHandler.java:86) at com.android.tools.idea.gradle.project.sync.idea.AndroidGradleProjectResolver.getUserFriendlyError(AndroidGradleProjectResolver.java:361) at org.jetbrains.plugins.gradle.service.project.GradleProjectResolver$ProjectConnectionDataNodeFunction.fun(GradleProjectResolver.java:769) at org.jetbrains.plugins.gradle.service.project.GradleProjectResolver$ProjectConnectionDataNodeFunction.fun(GradleProjectResolver.java:749) at org.jetbrains.plugins.gradle.service.execution.GradleExecutionHelper.execute(GradleExecutionHelper.java:227) at org.jetbrains.plugins.gradle.service.project.GradleProjectResolver.resolveProjectInfo(GradleProjectResolver.java:112) at org.jetbrains.plugins.gradle.service.project.GradleProjectResolver.resolveProjectInfo(GradleProjectResolver.java:72) at com.intellij.openapi.externalSystem.service.remote.RemoteExternalSystemProjectResolverImpl.lambda$resolveProjectInfo$0(RemoteExternalSystemProjectResolverImpl.java:37) at com.intellij.openapi.externalSystem.service.remote.AbstractRemoteExternalSystemService.execute(AbstractRemoteExternalSystemService.java:59) at com.intellij.openapi.externalSystem.service.remote.RemoteExternalSystemProjectResolverImpl.resolveProjectInfo(RemoteExternalSystemProjectResolverImpl.java:37) at com.intellij.openapi.externalSystem.service.remote.wrapper.ExternalSystemProjectResolverWrapper.resolveProjectInfo(ExternalSystemProjectResolverWrapper.java:49) at com.intellij.openapi.externalSystem.service.internal.ExternalSystemResolveProjectTask.doExecute(ExternalSystemResolveProjectTask.java:51) at com.intellij.openapi.externalSystem.service.internal.AbstractExternalSystemTask.execute(AbstractExternalSystemTask.java:138) […]

android studio的最低硬件要求?

我的系统configuration:英特尔Pentiunm双核1.3GHz与2GB内存。 我已经安装了Android Studio,但是很慢,我是Android开发新手。 升级RAM到4GB的帮助?