Articles of eclipse adt

按钮在Android中单击时播放声音

我是Android的新手,我正在尝试做一些简单的事情,比如点击按钮时播放自定义MP3。 这似乎是一个相当 普遍的 问题 ,但即使我的代码遵循示例,并且我没有收到任何错误,我在模拟器或真实手机中都听不到任何声音。 我的MainActivity.java: public class MainActivity extends Activity { private static final String TAG = “MyActivity”; public void MyActivity(Bundle onSavedStateInstance) { Log.v(TAG, “Initializing sounds…”); final MediaPlayer mp = MediaPlayer.create(this, R.raw.alarma_67560); Button play_button = (Button)this.findViewById(R.id.play_button); play_button.setOnClickListener(new View.OnClickListener() { public void onClick(View v) { Log.v(TAG, “Playing sound…”); mp.start(); } }); Log.v(TAG, “Sounds initialized.”); } […]

“Android私有库”不会出现在项目中

我的项目中缺少“Android私有库”项目(它没有出现在Eclipse的Project Explorer中)……看起来它似乎没有内置到项目中,因为我遇到了各种错误关于我的“libs”文件夹中的jar文件… 它确实出现在Java Build Path中(但它似乎是空的 – 在Libraries选项卡中没有jar文件出现),但我确实在那里检查了它。 如果它具有任何相关性,那么手头的项目也有很多Android库项目依赖项,在这些库项目中,libs /下的jar文件出现在Android Private Libraries下。

转换为Dalvik格式失败,错误1 – 更新Android SDK和ADT后

在为最新版本更新SDK和ADT之后,我尝试运行我的应用程序并且Eclipse记录以下错误: [- RichReaderDemo] Dx UNEXPECTED TOP-LEVEL EXCEPTION: java.lang.IllegalArgumentException: already added: Lbr/com/digitalpages/renderer/NewReaderActivity; [- RichReaderDemo] Dx at com.android.dx.dex.file.ClassDefsSection.add(ClassDefsSection.java:123) [- RichReaderDemo] Dx at com.android.dx.dex.file.DexFile.add(DexFile.java:163) [- RichReaderDemo] Dx at com.android.dx.command.dexer.Main.processClass(Main.java:486) [- RichReaderDemo] Dx at com.android.dx.command.dexer.Main.processFileBytes(Main.java:455) [- RichReaderDemo] Dx at com.android.dx.command.dexer.Main.access$400(Main.java:67) [- RichReaderDemo] Dx at com.android.dx.command.dexer.Main$1.processFileBytes(Main.java:394) [- RichReaderDemo] Dx at com.android.dx.cf.direct.ClassPathOpener.processArchive(ClassPathOpener.java:245) [- RichReaderDemo] Dx at com.android.dx.cf.direct.ClassPathOpener.processOne(ClassPathOpener.java:131) [- RichReaderDemo] Dx at […]

“此模板需要最低SDK版本”-Android Eclipse ADT插件报告错误的最小SDK。

我刚刚导入了我刚从我的git repo结帐的旧Android项目。 当我尝试使用Eclipse创建一个新的Master / Detail Flow Activity时: New > Android > Android Activity > Login Activity > Next Eclipse报告我错误说: This template requires a minimum SDK version of at least 3, and the current min version is 1 我在AndroidManifest.xml实际条目是: 谁能告诉我,我在这里失踪了什么? 我使用的是版本23.2 Android SDK Tools和Android SDK Platform-Tools版本19.0.1 。

将参数从按钮传递到android:onClick方法

嗨我在我的活动xml中有类似这样的东西(3个按钮)指向相同的方法: 有什么方法可以确定在printNo方法中按下了哪个按钮?

如何用src,res文件夹创建android jar项目

我想在另一个带有源和资源文件夹的项目中创建android项目用作jar库。 我已经创建了demo项目并通过从eclipse中选择src和res文件夹导出到jar中。 在我的jar项目中包含使用jar项目的布局xml文件表单资源的视图类。我在另一个项目中添加了demo.jar并运行然后它给出了错误。 如果我在不使用任何资源的情况下创建动态视图并使用该jar项目就可以正常工作。但是我想在该视图中使用jar项目的资源。

如何启动eclipse的多个实例(多个工作区)并使ADT插件正常工作?

当我想启动几个eclipse实例时,我遇到了eclipse和ADT plugin的问题。 什么工作(只有一个eclipse实例) 我用我的Android项目启动工作区 ,我可以调试,一切都很好。 我用我的Web项目切换到另一个 ,它也可以工作。 什么不起作用(eclipse的两个实例) 问题是当我用另一个工作区启动这些eclipse实例时,我遇到了以下问题: [2013-07-15 11:12:50 – ddmlib] An established connection was aborted by the software in your host machine java.io.IOException: An established connection was aborted by the software in your host machine 问题在于:已建立的连接已被主机中的软件中止 我知道如何重新启动eclipse,当它发生在一个实例时,它解决了我的问题。 有两个eclipse实例,它根本无法解决问题。 我想要的是(ADT工作的eclipse的一个实例和我的Web项目的另一个实例) 我可以有两个eclipse安装并启动一个安装了ADT插件并启动另一个我没有安装ADT,但我想只安装一个eclipse … 如何解决这个问题呢 ? 工作区配置? eclipse配置? ADT配置? 还要别的吗 ?

自动完成function在特定层次结构的XML文件中不起作用

特别是XML节点层次结构,例如。 DrawerLayout-> RelativeLayout-> ImageButton自动完成function无法按预期工作。 建议清单包含无效项目。 例如。 android:src没有显示在ImageButton里面。 提案无效: 另一方面,如果层次结构是RelativeLayout-> RelativeLayout-> ImageButton,则一切正常。 有效提案: 我已经尝试过了: 重新打开XML文件 – 没有效果 重新开放项目 – 没有效果 重启日食 – 没有效果

如何解决警告:您正在安装包含未签名内容的软件,并且无法建立此软件的真实性和有效性

我是Android新手。 我安装了Eclipse Kepler版本。 我按照这个链接。 https://sites.google.com/site/barsham/list-of-topics-1/programming/eclipse–android-windows-64 完成以下步骤后: 6.1。 启动Eclipse,然后选择Help> Install New Software …. 6.2单击右上角的“添加”。 6.3在显示的“添加存储库”对话框中,为“名称”输入“ADT插件”,并为“位置”输入以下URL: https://dl-ssl.google.com/android/eclipse/ 我尝试了https和httpurl。 但是相同的错误框popup窗口包含与未签名内容和真实性相关的警告。 请帮忙。

“插件org.eclipse.jdt.ui无法在adt中加载类org.eclipse.jdt.internal.ui.packageview.PackageExplorerPart。”问题(v22.6.2)

我的adt eclipse中出现了这个错误。 我正在使用java的更新版本。 请有人帮我解决这个问题。