Articles of eclipse

com.google.ads.AdView类错误

你好我是android dev和admob的新手。 我正在尝试使用按钮,几页和底部的admob制作一个简单的测试应用程序。 一切正常,直到我尝试实现admob。 这是我的代码: HelloAndroid.java: package com.manny.HelloAndroid; import android.app.Activity; import android.content.Intent; import android.os.Bundle; import android.view.View; import android.widget.ImageView; public class HelloAndroid extends Activity { /** Called when the activity is first created. */ private static final int ACTIVITY_CREATE = 0; @Override public void onCreate(Bundle savedInstanceState) { super.onCreate(savedInstanceState); setContentView(R.layout.main); ImageView image = (ImageView) findViewById(R.id.test_image); //image.setScaleType(ImageView.ScaleType.FIT_XY); } […]

无法使用Eclipse创建新的Android项目

我最近将我的sdk版本从18更新到20。 我试图创建一个新的Android应用程序项目。 我填写了所有需要的字段来创建一个新项目但是当我来到创建一个新的Android应用程序项目的最后一页时,会出现: “此模板取决于Android支持库,该库未安装,或者模板取决于比您安装的版本更新的版本。 所需版本:8已安装版本:未安装“ 然后它还会显示此链接。 http://developer.android.com/sdk/compatibility-library.html 它还有两个按钮: 安装/升级 再检查一遍 当我点击第一个按钮时,它不会下载,安装或升级我的任何软件。 此消息显示在我的控制台: [2012-07-15 21:55:08 – SDK Manager] Fetching https://dl-ssl.google.com/android/repository/addons_list-2.xml [2012-07-15 21:55:16 – SDK Manager] Fetched Add-ons List successfully [2012-07-15 21:55:16 – SDK Manager] Fetching URL: https://dl-ssl.google.com/android/repository/repository-7.xml [2012-07-15 21:55:37 – SDK Manager] Done loading packages. [2012-07-15 21:55:37 – Android Compatibility JAR not found:] D:\Software\Eclipse\v4\android-support-v4.jar 按钮2根本不做任何事情。 我下载了压缩文件’android-sdk_r20-windows’并将其解压缩到我的硬盘上。 […]

编译时编辑AndroidManifest以删除API密钥

我目前正在开发一个Android项目,并学习如何使用git。 我因为git问题而被阻止:我在我的android-manifest文件中声明了我的Google Maps api密钥: 现在,我想在github中推送我的代码,但是我无法推送我的AndroidManifest,因为它包含我的api密钥(它应该保密)。 我想知道是否有一种方法可以在每次推送之前修改它,或者每次编译我的应用程序时都可以修改它? 感谢您的帮助 !

Hello World Android应用程序,错误:workspace \ appcompat_v7 \ res \ values-v21 \ styles_base.xml找不到与给定名称匹配的资源

我是一个刚进入Android开发的新手。 我正在浏览官方Android开发人员网页上的”Building your first app ”教程。 我遵循了所有指令,但它在Eclipse中显示了这个错误代码。 错误消息很长,我想我的设置,SDK或环境肯定有问题。 任何人都可以帮我解决这个问题吗? 为了您的信息,我的目标SDK是API19 ,我也在使用API19编译 [2014-10-22 17:13:51 – appcompat_v7] WARNING: unable to write jarlist cache file C:\Users\Cliff\workspace\appcompat_v7\bin\jarlist.cache [2014-10-22 17:13:51 – appcompat_v7] WARNING: unable to write jarlist cache file C:\Users\Cliff\workspace\appcompat_v7\bin\jarlist.cache [2014-10-22 17:13:51 – appcompat_v7] WARNING: unable to write jarlist cache file C:\Users\Cliff\workspace\appcompat_v7\bin\jarlist.cache [2014-10-22 17:13:53 – MyFirstApp] C:\Users\Cliff\workspace\appcompat_v7\res\values-v21\styles_base.xml:75: error: Error retrieving […]

无法创建2.3.3 Intel Atom AVD(未finduserdata.img)

我已经阅读了所有相关问题,并没有find解决方案( “无法findABI armeabi的userdata.img文件…” ) 我可以毫无问题地在4.2.2下创建/运行Intel Atom AVD。 但是当我选择2.3.3作为目标时,我得到以下控制台错误: [2013-02-16 20:44:04 – SDK Manager] Unable to find a ‘userdata.img’ file for ABI x86 to copy into the AVD folder. 我尝试卸载/重新安装英特尔映像但没有成功。 我正在使用Android Developer Tools Build:v21.1.0-569685

如何在Eclipse中同时运行多个设备的Logcat

我有两个连接到同一站的Android设备。 我想在eclipse中以调试模式运行它们时查看两者的logcat。 我已经通过以下步骤获得了一些好运: 在设备1上运行应用程序 在设备2上运行应用程序 打开一个新窗口(窗口/新窗口) 在新窗口中,打开view logcat 大约40%的时间会导致每个eclipse窗口显示来自不同手机的数据……但并非总是如此。 它似乎几乎是一种运气般的东西。 通常两个窗口都显示相同的设备。 如果我打开设备查看器并在任一窗口中选择一个设备都会更改。 我怎么能一直这样做?

将Nexus上的Android升级到4.2.2后,Eclipse显示设备的目标未知?

我刚刚将手机升级到4.2.2,但现在我再也不能在日食中使用它了。 我尝试重启设备,重置我的调试设置,但我不能让它工作了。 我看到它已经是一个注册的问题 。 有一些新的安全增强function,因此应该有一个对话框(请参见底部),但此对话框不会出现。 我手机上没有几个账号,问题中指出了这个账号。 任何建议? 编辑:看下面接受的答案,这应该涵盖所有情况。 在我的情况下,有一些软件包丢失,但未在Android SDK Manager中显示。 我刚刚在Android SDK Manager中find了Packages – > Reload ……我认为这会自动发生

有什么方法可以从ImageButtons中删除灰色背景?

我有一个ImageButton,我想删除围绕图像的丑陋(恕我直言)背景。 我可以添加一个ImageView,但它们很难在布局中完美地设置,就像图中的灰色一样。 [重力“中心”不会让它向中间移动,只是垂直居中。) 那么有什么方法可以删除它吗?

有没有人为Eclipse IDE创建符合Android代码样式规则的Java代码格式化程序配置文件?

Android 代码样式指南定义“Android代码样式规则”。 为了符合这些规则,必须更改Java Code Formatter(Window-> Preferences-> Java-> Code Style-> Formatter)默认配置文件的许多设置(在Eclipse IDE中)。 有没有人设法将格式化程序配置为遵循“Android代码样式规则”? 如果是,请导出Formatter配置文件并发布以供社区使用。 PS:我自己尝试过这样做,但我发现格式器选项太多了,而且大部分都没有在代码风格指南中提到:-(

Android sdk安装。 错误:从元素’d:skin’开始发现无效内容。 此时不会有子元素

我在Linux Ubuntu 14.04上设置了eclipse和Android sdk环境。 我完全按照这个教程,现在我差不多结束了,但我得到了这个“在这一点上没有预期的子元素” 我需要做什么? 我是Linux的新手,是的,我已经find了答案,但我find的答案似乎与我需要的答案完全不符,因为我是新用户,我无法弄清楚这一点靠我自己。