Articles of eclipse

在Android上使用ProGuard

我在处理ProGuard和Android方面遇到了问题。 我在网上搜索了几个小时,发现了多种混淆Android应用程序的方法。 现在我正在尝试一个看起来最简单的,所以: 我在项目的根目录中创建了一个config.cfg文件 我在project.properties添加了proguard.config=config.cfg 我使用Eclipse导出向导导出和签署.apk文件 我收到一条消息,说Proguard returned with error code 1. See console和控制台: Proguard returned with error code 1. See console Note: there were 3847 duplicate class definitions. Warning: com.fasterxml.jackson.databind.ext.DOMSerializer: can’t find referenced class org.w3c.dom.bootstrap.DOMImplementationRegistry Warning: com.fasterxml.jackson.databind.ext.DOMSerializer: can’t find referenced class org.w3c.dom.bootstrap.DOMImplementationRegistry Warning: com.fasterxml.jackson.databind.ext.DOMSerializer: can’t find referenced class org.w3c.dom.bootstrap.DOMImplementationRegistry Warning: com.fasterxml.jackson.databind.ext.DOMSerializer: can’t find referenced […]

如何以编程方式崩溃Android应用?

我想用acra测试崩溃报告,但第一步是我需要使用代码模拟Android中的致命崩溃。 任何想法?

在Android Studio中创建新的图标集?

在Eclipse中有File|New|Android Icon Set…我如何在Android Studio中做同样的事情?

如何在Eclipse中安装Android ADT插件?

我按照ADT Plugin for Eclipse上的说明进行操作,但在Eclipse中安装时收到了此消息: Cannot complete the install because one or more required items could not be found Software being installed: Android Development Tools 0.9.9.v201009221407-60953 (com.android.ide.eclipse.adt.feature.group 0.9.9.v201009221407-60953) Missing requirement: Android Development Tools 0.9.9.v201009221407-60953 (com.android.ide.eclipse.adt.feature.group 0.9.9.v201009221407-60953) requires ‘org.eclipse.gef 0.0.0’ but it could not be found 我尝试过使用64位和32位Eclipse Galileo全新安装。 我使用的是Windows 7。 更新:我按照在Eclipse 3.5.1上安装Android开发工具所需的org.eclipse.gef 0.0.0上的步骤并安装了GEF SDK 3.5.2但是现在我在安装ADT时收到了一条新的类似错误消息: Cannot complete […]

在ListView中更改字体大小 – Android / Eclipse

如何更改ListView元素中的字体大小? 在我的main.xml文件中,我在android中尝试了几个不同的值:textSize(pt,px,sp,dp),似乎没有任何改变它。 这是我目前在main.xml中的内容: 这是我的Java: package com.SorenWinslow.TriumphHistory; import android.app.ListActivity; import android.os.Bundle; import android.widget.ArrayAdapter; public class TriumphHistory extends ListActivity { String[] HistoryList; /** Called when the activity is first created. */ @Override public void onCreate(Bundle savedInstanceState) { super.onCreate(savedInstanceState); setContentView(R.layout.main); ArrayAdapter adapter; HistoryList = getResources().getStringArray(R.array.history); adapter = new ArrayAdapter (this,android.R.layout.simple_list_item_1,HistoryList); setListAdapter(adapter); } }

Eclipse ADT:创建每个新项目后创建的项目名称“appcompat_v7”

好吧,我想强调这一点,并将其全部放在这个线程中,因为其余的线程没有得出结论的答案,所以在跳过它们之前,这里是我提到的线程: Adt不会创建默认的hello世界,但命令行会创建 [解决] Eclipse在创建新项目/活动时表现不同 自从过去几天以来,ADT一直表现得有些奇怪。 我保持我的SDK始终更新,所以我经常运行SDK管理器并下载所有更新。 最近我注意到,如果我创建一个新的Android应用程序项目它不会创建默认的MainActivity,即使我检查该框,它不会在src下创建一个Activity而更多的是为了惹恼我,我无法重构任何东西,所以我意识到在阅读了几篇文章之后,我不得不更新我的Eclipse,但现在当我创建每个新项目时,它会创建一个令人讨厌的appcompat_v7项目与每个项目,说我创建了两个新项目,它创建appcompat_v7_2 ….这让我疯狂,新项目库是appcompat_v7项目。 这变得很烦人,不知道这里发生了什么!!!! 我该怎么办…请救我! 在此先感谢….一个截图,惹恼你们… … 🙂 ***************目前的替代方案,不是解决方案*********************** 截至2014年12月5日ADT 23.0.2我再也看不到这个问题了。 我已经在这个问题上等待一个可接受的解决方案(截至目前还没有),但其中一位SO成员指示我访问此posthttps://code.google.com/p/android/issues/detail?id= 66975 我正在做的是在下面的一个解决方案中描述,但是对于那些来到这篇文章的人来说,另一种方法是删除那个已经创建的丑陋项目(如果你有多个)并加上这个项目(appcompat_v7) )作为一个图书馆。 因此,如果您创建另一个项目并且appcomat_v7_2 …出现删除并将项目指向appcompat_v7,也可以对其他项目执行相同操作。 不过,出于某些原因不建议这样做,但是直到现在它仍然没有问题。 如果有人点击解决方案,请在此处发布。 ****************当前替代方案,不是解决方案**************************** *

Android ADT版本22,未生成R.java文件

升级到Android ADT版本22并清理我的项目后,R.java文件丢失了。 我不能使用setViewContent(R.layout.activity_main),因为活动无法引用xml布局(由于缺少R.java)。 此外,当使用(ctrl + space)获取setContentView的建议时,不会输入代码。在查看错误日志时,它显示存在“未处理的事件循环exception”。 涉及的插件是org.eclipse.ui。 此外,每当我创建一个新的Hello World项目时,gen文件夹都是空的。 几个小时后,我尝试了android工作室。 但我不喜欢那里。 然后,当我回到Eclipse时,SDK平台工具和构建工具有了更新。 我更新了它们,但我仍然得到了错误。 我试过清理项目但没有运气。 什么似乎是问题?

Logcat消息在短时间后消失

有时eclipse日志消息会在关闭应用程序很短的时间后消失。 (大多数时间不那么短。)如何让它永远不会自动消失? 编辑:我的设备仍然附加。 以及如何将其设置为显示日志,即使在下次启动之前设备解除并清除之后?

用户操作正在等待后台工作完成

我正在使用eclipse junno为我的IDE开发android程序。 我的问题就像这样: 用户操作正在等待“构建工作区” 为什么会这样,我该如何解决? 关于这个案子我已经等了很多时间。 现在它看起来像这样。

无法解决目标’android-19′

我想使用Android API 19.我在project.properties文件中更改了target = android-19 。 在AndroidManifest.xml中。 我有这个 : 但在项目属性中我有这个: 如何将API级别更改为19以消除标题中的错误。 谢谢。