Articles of eclipse

在eclipse中使用Android build.xml?

我有一个Android项目,它有一个Ant构建文件。 它通过命令行很好用: rascher@coltrane:~/git/$ ant Buildfile: build.xml [setup] Android SDK Tools Revision 8 [setup] Project Target: Android 2.1-update1 [setup] API level: 7 [setup] … etc etc etc … 但是当我尝试在eclipse中使用它时, build.xml有一个red-X。 <project带有错误的下划线: 此项目中不存在默认目标帮助 看起来互联网上的其他人都有这个问题,这似乎是因为build.xml使用的指令来自这个buildfile导入的多个嵌套的特定于android的文件。 我的工作区中有其他项目使用Eclipse的构建机制,所以我知道我的环境能够编译,运行和部署Android应用程序而不会出现问题。 但是这个构建文件给我带来了麻烦。 修复是什么?

将项目导入Eclipse时,项目描述无效

我知道这个问题已在此处发布,但这并不能解决我的问题。 我从github分支中拉出一个项目,当我尝试导入它时: File->Import->General->Existing projects into workspace导入File->Import->General->Existing projects into workspace然后Select root directory ,这里当我点击Finish按钮时,我得到Invalid project description 。 我将项目拉入一个名为Android的文件夹,该文件夹包含我在Eclipse中导入的项目MyAndroidProject的主文件夹。 我不知道这里有什么问题。

仅在某些工作区中构建路径不完整(Android)

我有多个Eclipse(3.52“Galileo”))工作区,这样我就可以将相关项目保存在同一个工作区中。 我用File> Switch Workspace在它们之间切换。 我最近将一个好的,有效的项目复制到了一个不同的工作区,做了一个“文件>导入”来将它导入到它的新工作区中,但是在做了一个Clean和Build之后,得到了“ 该项目没有被构建,因为它的构建路径不完整。找不到java.lang.Object的类文件。修复构建路径然后尝试构建这个项目 “错误。 我所有的其他项目都很好。 我认为“构建路径”指的是搜索路径Java或SDK文件,那么为什么它只会在一个项目上失败(…在不同的工作区中构建良好的项目)? 我已经尝试重新启动eclipse,在工作空间之间来回切换,做另一个干净和构建,但没有运气。 有任何想法吗? 提前致谢。

带有android插件的Eclipse – 被阻止在“计算需求和依赖性”

在Eclipse中安装Android时遇到问题(Indigo和Helios,我尝试了很多不同的版本)。 当我使用地址http://dl-ssl.google.com/android/eclipse/或localy(使用存档)搜索插件时,它无效。 它find了开发工具,但它阻止了“计算需求和依赖性”。 有什么问题 ?

在android中重命名项目的简便方法

我已经下载了一个Android项目。 为了避免名称冲突,我想将它从com.android.zzz移动到com.my.zzz。 目前我正在使用Ecplise和标准的android工具包。 有没有比手动浏览文件更好的方法进行重命名?

如何使用Eclipse在Android设备上运行应用程序?

我正在为Android开发我的第一个应用程序,现在我使用ADT运行应用程序,现在我想在Android设备上运行应用程序,我该怎么做,需要帮助。 提前致谢

无法执行dex:java.nio.BufferOverflowException。 检查Eclipse日志中的堆栈跟踪

每次我想运行我的Android应用程序时都会出错: [2013-12-26 11:24:12 – Dex Loader] Unable to execute dex: java.nio.BufferOverflowException. Check the Eclipse log for stack trace. [2013-12-26 11:24:12 – Pk6.1.3] Conversion to Dalvik format failed: Unable to execute dex: java.nio.BufferOverflowException. Check the Eclipse log for stack trace. 我从project > properties > java build path > libraries删除了Android依赖项。 我清理项目后没有运行它。 我修改了project.properties文件, target=android-19 ,然后运行它,但我不想这样做。 还有其他解决方案可以解决这个问题吗? 谢谢。

Android SDK需要Android开发人员工具包版本17.0.0或更高版本

当我试图将我的项目从eclipse合并到netbeans时,我遇到了这个奇怪的问题。 现在,当我试图重新运行eclipse时,我得到了这个错误 “Android SDK需要Android开发人员工具包版本17.0.0或更高版本” 我试图解决这个问题的方法是尝试更新其中的SDK和工具包。 到目前为止,一切都在更新,现在我一无所知。

在adb安装上INSTALL_PARSE_FAILED_INCONSISTENT_CERTIFICATES

同样的Android项目是在调试模式下构建的,有时使用Eclipse,有时使用ant(在构建机器上)。 如果我首先安装ant build,然后尝试启动Eclipse调试,则会显示Eclipse控制台 [2012-03-20 13:32:26 – myproject]由于应用程序签名不同,重新安装失败。 [2012-03-20 13:32:26 – myproject]您必须执行应用程序的完全卸载。 警告:这将删除应用程序数据! [2012-03-20 13:32:26 – myproject]请在shell中执行’adb uninstall com.myproject’。 [2012-03-20 13:32:26 – myproject]发布取消! 如果我这样做,反过来,即使用Eclipse调试(包括安装apk),然后尝试从命令行安装ant build,我得到: 失败[INSTALL_PARSE_FAILED_INCONSISTENT_CERTIFICATES] 我的证书/签名有什么问题?

Eclipse不断启动新的模拟器

我正忙着学习如何为Android构建应用程序,我遇到了一个非常尴尬的问题。 当我运行我的应用程序时(带有播放图标的绿色圆圈),它会启动Android模拟器(就像它应该的那样),但是一旦模拟器启动,应用程序就无法启动。 当我再次单击运行按钮时,它会尝试启动第二个android-emulator。 在控制台选项卡中,它提供以下消息: [2011-11-07 20:57:15 – ScrollView Demo] Android Launch! [2011-11-07 20:57:15 – ScrollView Demo] adb is running normally. [2011-11-07 20:57:15 – ScrollView Demo] Performing testapp.scrollviewdemo.MainActivity activity launch [2011-11-07 20:57:15 – ScrollView Demo] Automatic Target Mode: launching new emulator with compatible AVD ‘Android_emulator’ [2011-11-07 20:57:15 – ScrollView Demo] Launching a new emulator with Virtual […]