Articles of eclipse

当Eclipse for Android Project Dev时,“无法启动选择并且最近没有启动”

我正在尝试使用Eclipse打开一个解压缩的Android项目,但每次我尝试运行或调试时都会显示此错误:“选择无法启动且最近没有启动”。 所以我查了一下,尝试从现有的源创建一个新项目,但打开时出错,我打开了src等文件夹。 我也试过导入那个也不起作用的项目。 没有作为选项运行,更改运行配置并没有真正帮助。 我找不到任何选项将其作为Android项目打开。 你能不能帮我运行这个项目。 (因为我解压缩了这个项目,导入时有一个_MACOSX文件夹,我不确定这是否重要,或者我应该删除该文件夹。)

如何从一个代码库创建多个Android应用程序

我有一个Android代码库,它使用带有设置的API来获取多个应用程序的不同数据。 所有应用程序使用相同的代码库,但有一个或两个设计调整。 那么如何重新使用主代码库而不必每次都复制整个Android项目呢? iPhone在同一个项目中使用多个目标,效果很好。 如果android不能这样做,我需要在一个项目中编译代码库的二进制文件,然后导入到每个新的应用程序项目? 如果是这样的话? 我正在使用Eclipse并且是一名中级Java开发人员。 任何帮助非常感谢! 道格

与adb的连接已关闭,并且发生了严重错误。您必须重新启动adb和Eclipse。请确保adb已正确定位

我知道这个问题被多次询问,也有一些替代答案。所以请不要关闭其他链接,因为我已经在下面添加了这个链接。 [2014-01-23 16:19:44 – adb] ADB server didn’t ACK [2014-01-23 16:19:44 – adb] * failed to start daemon * …. …. [2014-01-23 14:48:10 – My App] The connection to adb is down, and a severe error has occured. [2014-01-23 14:48:10 – My App] You must restart adb and Eclipse. [2014-01-23 14:48:10 – My App] Please […]

Android:构建路径中的错误

当我更新eclipse软件并运行应用程序时,错误显示为: “容器’Android Dependencies’引用了不存在的库’C:\ Project \ android-sdk-windows \ tools \ support \ annotations.jar’。 请帮我清除此错误并运行应用程序。

无法将项目导入Eclipse工作区

所以,我多年来一直在Windows中使用eclipse。 我有一些我最近一直在努力的android项目。 但我却陷入了如此奇怪的困境。 问题是我现在在Windows和Linux上使用eclipse。 (是的,我觉得linux更好,更快)。 我希望将我在Windows上使用的所有项目都放到Linux Eclipse工作区中(是的,我创建了另一个工作区,因为我不知道我是否可以在两个版本的viz linux和windows eclipse中使用相同的工作区)。 现在,奇怪的部分是我无法将这些项目导入我的其他工作空间! 这真让我抓狂。 我去我的Linux Eclipse工作区 – >导入 – >添加现有的android proj – >浏览 – >我的android项目的根目录 – >(Ecipse确实在下面的框架上显示项目 – >我点击完成 – > 没什么 。我只是坐在那儿,等待,没有任何反应。我在stackoverflow中搜索过这里,但没有一个问题类似于此。 是的我可以访问工作区文件夹,是的我可以创建文件夹等。 有人可以告诉我如何导入被检测但未导入的项目吗? 谢谢。

如何在Eclipse中获取Android API文档

我希望能够将Android api文档集成到Eclipse中,例如,如果将鼠标hover在Activity类上,则会在popup窗口中获得相应的Javadoc。 因此,要将Javadoc添加到Android,您可以在Eclipse中打开任何Android项目。 定位“Android xx”库。 在此右键单击android.jar文件并选择Properties。 选择Javadoc位置条目。 在JavadocURL部分,我输入了http://developer.android.com/reference/packages.html并单击了Validate但它给出了通常的错误 位置可能无效。 尚未find通常在Javadoc工具创建的文档的根目录中提供的文件’package-list’和’index.html’ 我已尝试过该url的大量变体,但无济于事。 我也不想不得不下载Android的源代码。

让我们解决“当前主题中找不到风格’mapViewstyle’的错误”

很抱歉发布另外一个,但似乎我们还没有记录这个问题的每个解决方案。 这是发生的事情:我添加了一个mapview,一切都在工作。 我添加了一个滑动抽屉并将按钮移入其中,然后将根节点从线性更改为相对。 从那时起,我在读取的main.xml类的图形布局中出现错误 缺少风格。 是否为此布局选择了正确的主题? 使用布局上方的“主题”combobox选择不同的布局,或修复主题样式引用。 无法在当前主题中find样式’mapViewStyle’。 将根节点切换为线性节点并返回到相对节点已使地图显示,但错误仍在图形布局中。 到目前为止,我已经完成了以下解决方案,可以解决大多数情况下的问题: 添加了style.xml以创建“mapView”样式。 validation我的构建目标是API 2.3.3(10) 确保是Application的子节点。 清理/重建我的应用程序。 删除了R. 删除并重建了main.xml 重新启动了adb服务器,Eclipse,我的计算机和我的设备。 在图形布局中,在Android 3.0和Android 2.3.3之间切换。 但是,我的问题仍然存在。 这是我的布局xml。 这是我的清单xml。 如果有人有解决方案,请告诉我。 如果我弄清楚的话,我会尽力回复。

Eclipse Juno ADT插件删除了NDK路径?

我找不到使用ADT插件在Eclipse Juno上设置NDK路径的选项。 (我昨天从Android网站下载了ADT Bundle)。 每个人都说我应该在Windows下find它 – >首选项 – > Android – > NDK但Android下的NDK选项根本不存在。 也许他们在最近的版本中更改了它的位置? 无论如何,我似乎无法find一种方法来改变Eclipse中的NDK路径。 图片: 我觉得我错过了一些非常明显的东西……

在Eclipse中创建新项目后,将自动创建“appcompat_v7”项目

创建任何新的android项目后,Eclipse会自动创建一个“appcompat_v7”项目,而没有/ src下的任何文件。 我不知道Eclipse是如何或为什么创建这个项目的。 我也遇到了一个奇怪的错误。 如您所见,项目中存在AndroidManifest.xml! 编辑1:清理项目后,奇怪的错误消失了,但我仍然想知道为什么appcompat_v7被创建。 EDIT2:我还注意到Eclipse会在/ res / layout下自动创建一个新布局fragment_main.xml。 为什么?? 我创建了一个新的Workspace,并尝试了几次。 但我仍然有这个问题。 编辑3:如果您选择API 14之后的最低SDK版本,您将无法获得此支持文件夹。

“创建项目”菜单中的API集成的Eclipse插件和ADT修改

我计划创建一个与Android项目的API集成相关的插件。 我可以检查/标记我要添加的API,它应该添加所有相关文件,并将示例集成在Main_Activity /或用户创建的默认活动中。 作为首发,我需要知道: 1)我是否只需要开始研究eclipse代码或ADT插件? 2)是否有任何此类插件可用? 3)我需要从哪个类别的ADT开始学习,以便我可以在Create android project菜单中开始学习它? 到目前为止,我已经开始检查ADT代码了。 网上什么都没有,所以我无法告诉你我做了什么。