Articles of eclipse

该项目引用RTL属性,但不明确启用或禁用RTL支持

在Eclipse清单文件中,我收到一条警告消息。 应用程序的语言是土耳其语(不是左到右)。 “该项目引用了RTL属性,但没有明确地启用或禁用清单中的android:supportsRtl对RTL的支持” 我不能添加android:supportsRtl行,因为我的min sdk versionn是9.这个警告很重要? 谢谢

无法parsing“adb版本”的输出?

我正在运行Windos 7和Eclipse 3.5,我不知道为什么我一直得到这个错误。 当我尝试运行该程序,它给了我: [2010-02-13 23:09:41 – HelloAndroid]The connection to adb is down, and a severe error has occured. [2010-02-13 23:09:41 – HelloAndroid]You must restart adb and Eclipse. [2010-02-13 23:09:41 – HelloAndroid]Please ensure that adb is correctly located at 'C:\Users\Mohit\Documents\AndroidSDK\tools\adb.exe' and can be executed. 我甚至尝试运行Eclipse和adb.exe作为pipe理员。 到底是怎么回事? 我如何解决这个问题,并开始制作Android应用程序?

SecurityException:无法finddex.jar的字段

我如何解决这个错误? 我试过了: 刷新项目,并重build。 清理项目,重build。 closures和重新开放这个项目,并重build 删除项目(但不删除文件 – 这是项目删除确认对话框上的checkbox),然后将其重新导入为现有项目,并进行清理和重build。 删除项目,删除项目中的.project和.classpath文件,并使用我的文件作为现有源创build一个新项目。 这些都没有工作。 我如何解决这个问题?

使用Eclipse Juno 4.2.0安装Android插件错误

我下载了Eclipse-Juno版本:4.2.0 。 但是我无法在其上安装Android ADT。 我得到这个错误: 需要'org.eclipse.wst.sse.core 0.0.0',但找不到 系统configuration:Win-7,32位 我尝试安装ADT-15.0.1和ADT-16.0.1 ,但他们不工作。 我知道同样的问题是版本低于3.7的版本 ,但为什么还与4.2?

在Android应用程序中使用commonc编解码器的NoSuchMethodError

我在eclipse中添加了来自apache.org(commons-codec-1.4.jar)的commons编解码器,用于我的Android应用程序。 代码中没有错误。 但是当我运行应用程序并调用使用编解码器的函数时,应用程序停止并需要closures。 在logCat中说: Android运行时:java.lang.NoSuchMethodError:org.apache.commons.codec.binary.Base64.encodeBase64String 代码行是:String tmpStr = Base64.encodeBase64String(msg); // msg是一个字节[] 该应用程序是一个最小SDK版本= 7(Android 2.1),所以我不能使用Android Base64 任何想法我怎么能解决这个问题?

Android Eclipse NoClassDefFoundError用于外部.jar文件

我遇到了一个奇怪的错误。 我有一个使用外部库的Android项目,特别是: android-support-v4.jar(用于Android 1.6中的Fragment支持) GoogleAdMobAdsSdk-4.3.1.jar(针对广告) 该项目运行良好,直到我更新了插件的某些方面(不记得具体细节,因为我没有太多的关注),然后,每当我尝试使用上述.jar文件(或任何类它的子类,甚至是由我定义的),我会得到一个java.lang.NoClassDefFoundError。 经过多次search,我找不到答案,所以我真的很难过。 我相信这个问题与我的IDE设置有关,它与实际代码很less有关,所以除非是绝对必要的,否则我不会发布。

导入android.support.v7无法parsing

我是Android新手。 目前,我已经安装了adt-bundle-windows-x86-20131030.zip (Windows 32位),并成功安装了Android SDK和Eclipse。 另外,我已经更新了Android SDKpipe理器中的所有内容。 现在,我正在使用Android v-4.4.2 我的项目运行成功,但是当我导入android.support.v7.app.ActionBarActivity; 并import android.support.v7.app.ActionBar; 该项目将不会debugging。 我得到的错误The Import android.support.v7 cannot be resolved 我在Google中search并安装了Android Support Library然后在我的项目中添加了v7 。 文件 – >导入(android-sdk \ extras \ android \ support \ v7)。 select“appcompat” Project-> properties-> Android。 在部分库“添加”,并select“appCompat” 截图 成功添加到appCompat但仍然是我得到的错误。

此Android SDK需要ADT版本23.0.0或更高版本。 当前版本是22.6。 请更新ADT到最新版本?

我从本网站Developer.Android下载并安装了带有SDK SDK for Windows的Eclipse ADT。 当我尝试创buildAVD设备时出现错误, Location of Android SDK has not been setup in Preferences. 我从Windows菜单栏打开Preferences ,然后我尝试设置SDK位置,但它显示错误此Android SDK需要ADT版本23.0.0或更高版本。 当前版本是22.6。 请更新ADT到最新版本。 如何更新它? 帮我创build一个android项目。

在ADT上运行构build器“Android资源pipe理器”时出错

当我尝试在eclipse adt插件工具中创build新的android项目时,我遇到了一个问题。 错误/exception:: Errors occurred during the build. Errors running builder 'Android Resource Manager' on project 'test'. java.lang.NullPointerException 我以前曾经遇到这个问题两次。 唯一的解决办法是重新安装Windows操作系统,这实际上解决了问题。 但我想要一个真正的解决scheme,无需重新安装Windows。

android.annotation无法parsing

我试图在Eclipse中运行示例android代码,但是当我尝试: import android.annotation.SuppressLint; 我不断收到与此行相关的错误,如: the import android.annotation cannot be resolved 如果有人能帮助我,我将不胜感激。