Articles of ubuntu

使用’ionic emulate android’命令时,Android模拟器无法安装应用程序

我是Ionic和Android编程的新手,所以如果有任何不便,我很抱歉。 我的问题是我无法在模拟的android虚拟设备上看到我的应用程序(教程中的默认应用程序)。 它只是在我运行ionic emulate android后显示一个股票Android手机。 所以我假设应用程序没有安装在模拟器上。 它构建了apk但似乎没有对它做任何事情。 我想我正确地安装了所有想法: > duc@duc-ThinkPad-T450s:~/myApp$ ionic info Your system information: > Cordova CLI: 6.0.0 Ionic Version: 1.2.4 Ionic CLI Version: 1.7.14 > Ionic App Lib Version: 0.7.0 OS: Distributor ID: Ubuntu Description: > Ubuntu 14.04.4 LTS Node Version: v4.4.1 我希望你能帮助我,只是想让教程继续:) 迎接,公爵 编辑 : 我终于设法使用此命令手动将apk安装到模拟设备: adb -s install 然而,手动安装它是非常不方便和烦人的。 有人有解决方案吗?

错误:尝试在Ubuntu 15.10中构建Ionic应用程序时生成EACCES

过去几周我一直在使用cordova /离子项目。 我用windows进行开发。 但最近我不得不将我的开发环境改为Ubuntu。 我使用Ubuntu 15.10。 尝试在设置Android SDK之后在Ubuntu中构建相同的项目,JDK ANT等,给了我这个错误。 我可以毫无问题地“离子服务”或“cordova服务”。 尝试删除并重新添加平台android但问题是相同的。 以下是错误。 user@myhost:~/works/myproject$ ionic build android Running command: /home/user/works/myproject/hooks/after_prepare/010_add_platform_class.js /home/user/works/myproject add to body class: platform-android Running command: /home/user/works/myproject/hooks/after_prepare/020_remove_sass_from_platforms.js /home/user/works/myproject Running command: /home/user/works/myproject/platforms/android/cordova/build ANDROID_HOME=/home/user/android JAVA_HOME=/usr/lib/jvm/java-8-oracle Running: /home/user/works/myproject/platforms/android/gradlew cdvBuildDebug -b /home/user/works/myproject/platforms/android/build.gradle -Dorg.gradle.daemon=true error caught: Error: spawn EACCES /home/user/works/myproject/platforms/android/cordova/node_modules/q/q.js:126 throw e; ^ Error: spawn EACCES at exports._errnoException (util.js:874:11) […]

Eclipse无法启动(Ubuntu):JVM终止。 退出代码= 2

我安装ubuntu 14.04 LTS(64位) 之后安装Eclipse Luno Standard for 64bit 安装Jdk并按照以下链接执行设置jdk的所有步骤, http://www.wikihow.com/Install-Oracle-Java-JDK-on-Ubuntu-Linux 然后在我启用我的eclipse之后它给了我一个跟随错误, VM终止。 退出代码= 2 /usr/bin/java -Dosgi.requiredJavaVersion=1.6 -XX:MaxPermSize=256m -Xms256m -Xmx1024m -jar /home/eheuristic/Ecclipse/eclipse//plugins/org.eclipse.equinox.launcher_1.3.0.v20140415- 2008.jar -os linux -ws gtk -arch x86_64 -showsplash /home/eheuristic/Ecclipse/eclipse//plugins/org.eclipse.platform_4.4.0.v20140925- 0400/splash.bmp -launcher /home/eheuristic/Ecclipse/eclipse/eclipse -name Eclipse –launcher.library /home/eheuristic/Ecclipse/eclipse//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1. 200.v20140603-1326/eclipse_1605.so -startup /home/eheuristic/Ecclipse/eclipse//plugins/org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar –launcher.appendVmargs -exitdata 208017 -product org.eclipse.epp.package.java.product -vm /usr/bin/java -vmargs -Dosgi.requiredJavaVersion=1.6 -XX:MaxPermSize=256m -Xms256m -Xmx1024m -jar /home/eheuristic/Ecclipse/eclipse//plugins/org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar 我这么多尝试解决设置环境variables但不能做,帮我一个建议如何解决它。

为什么ADB Ubuntu无法识别我的设备?

我买了一台摩托罗拉G,我尝试从DEVELOPED ADT Ubuntu安装我的程序,问题是我在ejercutar应用程序时收到消息 从终端,显示以下内容 zhelon@zhelon-Lenovo-IdeaPad-Z400:~$ sudo adb devices List of devices attached ???????????? no permissions

Ubuntu,无法启动react-native:找不到tools.jar

我按照入门指南 Android / Linux进行操作。 我尝试使用react-native run-android在ubuntu下启动本机react-native run-android ,但它失败并出现错误: FAILURE: Build failed with an exception. * What went wrong: Execution failed for task ‘:app:compileDebugJavaWithJavac’. > Could not find tools.jar 我该如何解决? 全输出: $ react-native run-android Starting JS server… /bin/sh: 1: adb: not found Building and installing the app on the device (cd android && ./gradlew installDebug… :app:preBuild […]

如何在Ubuntu上使用openjdk构建android项目?

我发现在Ubuntu 10.10上使用Android SDK真的需要Sun Java吗? 我更喜欢OpenJDK,但我无法在Ubuntu上构建android项目。 当我尝试: $ ant debug 我有: Unable to locate tools.jar. Expected to find it in /usr/lib/jvm/java-6-openjdk/lib/tools.jar … BUILD FAILED /home/kuba/projects/Android/android-sdk-linux/tools/ant/build.xml:651: The following error occurred while executing this line: /home/kuba/projects/Android/android-sdk-linux/tools/ant/build.xml:672: Unable to find a javac compiler; com.sun.tools.javac.Main is not on the classpath. Perhaps JAVA_HOME does not point to the JDK. It is […]

在ubuntu 10 64bit上安装java时出错

编辑 我添加了这个说明来解释为什么我在这里保留这个问题。 我添加了“Android”作为关键字,我想知道是否其他人试图下载代码以及如何解决这个问题。 我担心如果我问Ubuntu他们会建议我使用OpenJDK,但问题是:有人使用该SDK来构建Android代码吗? 原版的 前段时间我在Ubuntu 10 64bit上下载了android源代码。 我遇到了问题,但最后我设法让一切正常。 现在我想在同一个Ubuntu版本的全新安装上再次尝试,但我遇到了问题。 虽然我遵循了这里的说明,但我仍然遇到错误: 包sun-java6-jdk不可用,但是由另一个包引用。 这可能意味着包丢失,已被淘汰或仅可从其他来源获得E:包sun-java6-jdk没有安装候选 谷歌搜索为您提供了许多结果,为您提供相同的解决方案: sudo add-apt-repository “deb http://archive.canonical.com/ lucid partner” sudo apt-get update sudo apt-get install sun-java6-jdk 我做到了但它没有用。 我在VMWare下的VM上运行Ubuntu。 我还试图添加另一个来源: sudo add-apt-repository“deb-src http://archive.canonical.com/ubuntu lucid partner 但它没有帮助 也许答案就在这里: 在SuperUser中回答 但奇怪的是,在Android门户网站上没有任何提及它

Android Studio – 无法确定Java版本

我使用终端安装了Android Studio的新副本,但是当我创建一个新项目时,它会出现错误“无法确定Java版本”。 JDK和SDK都已安装。 Android Studio已更新至最新版本。 我使用的是Ubuntu 14.04 LTS 感谢您的帮助

adb不能在Ubuntu 64上运行 – 找不到命令

更新 在做了一些实验之后,我必须完全改写我的问题,因为我被我的终端所欺骗。 当我发出sudo ./adb时,它没有显示错误消息。 如果我进入ANDOID_SDK / platform-tools目录并运行./adb ,我得到: command not found: ./adb 这里输出ls -l adb在同一目录中: -rwxrwxr-x 1 myuser myuser 159620 2011-12-20 19:30 adb 运行哪个adb给了我: ./adb 对于该目录中的所有其他二进制可执行文件,例如aapt,aidl,dexdump等,也会发生同样的情况。 我可以想象这与我试图在64位Ubuntu上运行它有关,但ELF标题或类似的东西无法被识别。 但是,ANDOID_SDK / tools中的android工具运行正常(除了在下载新包后未能执行adb)。 真奇怪…… 原始问题 我下载了最新的Android SDK。 如果我尝试以普通用户身份运行adb,我会收到“找不到命令”。 我必须将其作为“sudo ./adb”运行并且它有效。 为什么这样,我该如何解决? 我正在运行Ubuntu 64 11.10。 我在较旧的Ubuntu版本上使用了SDK,我可以像普通用户一样运行它而不会出现问题。 有任何想法吗?

Android,设置Linux构建环境,libgl1-mesa-glx:i386包具有未满足的依赖性

我正在尝试为AOSP建立一个Linux构建环境。 我有Ubuntu-12.04.4-desktop-amd64分配。 我按照这里给出的指示做了一切。 我输入terminal命令来安装必要的包: $ sudo apt-get install git gnupg flex bison gperf build-essential \ zip curl libc6-dev libncurses5-dev:i386 x11proto-core-dev \ libx11-dev:i386 libreadline6-dev:i386 libgl1-mesa-glx:i386 \ libgl1-mesa-dev g++-multilib mingw32 tofrodos \ python-markdown libxml2-utils xsltproc zlib1g-dev:i386 然后我收到一条错误消息: The following packages have unmet dependencies: libgl1-mesa-glx:i386 : Depends: libglapi-mesa:i386 (= 8.0.4-0ubuntu0.7) Recommends: libgl1-mesa-dri:i386 (>= 7.2) E: Unable to correct […]