Android开发工具23.0.0和Android L在eclipse中更新错误

我使用最新版本的Android L更新了我的SDK,并重新启动了我的eclipse,即在ADT V.22上运行。 但是,当我检查从Hep -> Check for updates更新Hep -> Check for updates ,它说No updates were found

我手动尝试从官方网站下载ADT软件包,并试图从Help -> Install New Software安装ADT-23.0.0.zip ,并介绍了网站上的安装指南,但它给了我错误

  Cannot complete the install because of a conflicting dependency. Software being installed: Android Development Tools 23.0.0.1245622 (com.android.ide.eclipse.adt.feature.feature.group 23.0.0.1245622) Software currently installed: Google App Engine Tools for Android 3.5.1.v201312301719-rel-r42 (com.google.gdt.eclipse.mobile.android.feature.feature.group 3.5.1.v201312301719-rel-r42) Only one of the following can be installed at once: ADT XML Overlay 22.6.3.v201404151837-1123206 (overlay.com.android.ide.eclipse.adt.overlay 22.6.3.v201404151837-1123206) ADT XML Overlay 23.0.0.1245622 (overlay.com.android.ide.eclipse.adt.overlay 23.0.0.1245622) Cannot satisfy dependency: From: Android Development Tools 23.0.0.1245622 (com.android.ide.eclipse.adt.feature.feature.group 23.0.0.1245622) To: overlay.com.android.ide.eclipse.adt.overlay [23.0.0.1245622] Cannot satisfy dependency: From: Android Development Tools 22.6.3.v201404151837-1123206 (com.android.ide.eclipse.adt.feature.group 22.6.3.v201404151837-1123206) To: overlay.com.android.ide.eclipse.adt.overlay [22.6.3.v201404151837-1123206] Cannot satisfy dependency: From: Google App Engine Tools for Android 3.5.1.v201312301719-rel-r42 (com.google.gdt.eclipse.mobile.android.feature.feature.group 3.5.1.v201312301719-rel-r42) To: com.android.ide.eclipse.adt.feature.group 22.0.0 

而且在编译我正在更新之前完美运行的正在运行的项目时,它也会给我错误。 错误是:

 [2014-06-27 12:03:01 - my App] The connection to adb is down, and a severe error has occured. [2014-06-27 12:03:01 -my App] You must restart adb and Eclipse. [2014-06-27 12:03:01 - my App] Please ensure that adb is correctly located at 'E:\Android-sdk\adt-bundle-windows-x86_64-20130522\sdk\platform-tools\adb.exe' and can be executed. 

我厌倦了之前提供的用于杀死adb服务器的各种解决scheme,并使用adb kill-server命令重新启动。

任何人都可以解决或指导我如何构build和编译现有的项目与Eclipse中的这个新的SDK更新。

Solutions Collecting From Web of "Android开发工具23.0.0和Android L在eclipse中更新错误"

我有同样的问题,只是解决了它。 我所做的是完全卸载eclipse的android插件 (从“关于”部分..),包括跟踪视图..

此时不要重新启动eclipse!

然后再添加ADT插件( https://dl-ssl.google.com/android/eclipse/

问题解决了!

我想这是SDKpipe理器或ADT插件更新机制的错误。

这节省了我的一天…!

如果由于某种原因,您安装了ADT预览并需要恢复到当前的稳定版本,则不能使用该对话框来安装“新”软件,因为您想要的是实际上较旧的软件。 而是这样做:

  • 在Windows或Linux上打开“帮助”>“关于Eclipse …”。 在Mac上,使用应用程序的菜单>关于…
  • 点击“安装细节”button。
  • select“安装历史”选项卡。
  • select一个以前的configuration。
  • 点击底部的“恢复”button。

在这里输入图像说明

我依赖于这篇文章如何从.zip安装Eclipse的插件 ,我做了很多工作。 仍然需要我的一些修复。 我会尽快更新。

这是基于打开ADT插件zip文件并手工复制它的内容的想法,一种老式的复制粘贴方法。 我仍然无法完成configuration,但工具确实有效。

在这之前不要忘记卸载旧的ADT。

我有同样的问题,最后我不得不从http://developer.android.com/sdk/index.html下载一个新的ADT比试图打vs vs依赖或adt版本更快。