导入Android项目到Eclipse的问题

我重新安装了我的电脑,现在尝试将我的Android项目导入工作区。 (File – > Import – > General – > Existing Project into Workspace)

但是现在我有一个奇怪的错误。

bNormal.setOnClickListener(new OnClickListener() { @Override public void onClick(View v) { gotoNextQuestion(); } }); 

在第二行(@Override)eclipse总是告诉我有一个错误:

 /* Multiple markers at this line - implements android.view.View.OnClickListener.onClick - The method onClick(View) of type new View.OnClickListener(){} must override a superclass Method */ 

这发生在任何地方,在@Override使用。 我已经尝试过Android-Tools -> Fix Project SettingsProject -> Clean

我希望有人能帮助我解决这个奇怪的问题。

谢谢,马克

Solutions Collecting From Web of "导入Android项目到Eclipse的问题"

这是因为语言级别设置为5.0。 将其更改为6,所有将正常工作。 不知道在哪里设置日食,但在想法它是文件 – 项目结构 – 项目语言级别

发生这种情况是因为OnClickListener是一个接口,而在Java中, @Override OnClickListener不能应用于方法实现。

您的android SDK可能不在相同的path。 修复你的eclipse设置。