Android操作栏如何为Eclipse添加支持库v7 appcompat

我遵循Android中的每个步骤- ActionBar添加操作栏。 我从ActionBarActivity扩展活动:public class MainActivity extends ActionBarActivity

我需要添加appcompat v7支持库,如下所示:在“添加资源库”,eclipse部分。 最后一步:

“将库添加到您的应用程序项目中:

  1. 在Project Explorer中,右键单击您的项目并selectProperties。
  2. 在“库”窗格中,单击“添加”。
  3. select库项目,然后单击确定。 例如,appcompat项目应该被列为android-support-v7-appcompat。
  4. 在属性窗口中,单击确定。 “

第2步是我无法find库窗格。 我怎样才能将库添加到我的项目?

Solutions Collecting From Web of "Android操作栏如何为Eclipse添加支持库v7 appcompat"

一张图片胜过千言万语: 在这里输入图像说明

以下是步骤:

  1. 粘贴你已经下载到项目的libs文件夹中的android-support-v7-appcompat.jar
  2. 右键单击你的项目,selectBuild Path – > Configure build path
  3. selectLibrary Tab然后Add Jar选项并浏览最近添加的v7 jar,然后单击OK

而已 :)

这对我来说是有效的:

  1. Eclipse – >导入 – >现有的Android代码到工作区。
  2. 将〜/ android / adt-bundle-mac-x86_64 / sdk / extras / android / support / v7 / appcompat添加到您的Eclipse工作区。
  3. 在Eclipse中右键单击项目并select属性。
  4. selectAndroid – >库 – >添加。
  5. selectappcompatv7项目并保存。

使用导入android.support.v7.app.ActionBar在活动和片段中导入Action栏。

如果在左侧列表中首先select了android,库窗格将显示出来。 它应该位于Project Build Target部分下的属性窗口的右侧部分的底部。

这是我用来解决这个问题的解决scheme。

  1. 请确保您已经安装了以下库Android安装支持库,Android支持库和Google Repository ,方法是在eclipse中打开Android SDKpipe理器来检查Extra文件夹。
  2. 创build一个Android示例项目,然后selectappcompact_v7库。
  3. closures刚刚创build的项目,重新启动Eclipse,现在创build一个新的Android应用程序项目

希望它能帮助你。

在这种情况下,

在“android-support-v7-appcompat”项目中:

 -Delete “android-support-v7-appcompat” from Package explorer. -Import again and check “Copy into workspace” -In Properties -> Android -> in Project build target, uncheck Android 2.2 and check Android 4.1.2 -In Java build path, uncheck if you have any .jar library, and uncheck the Dependence 

另一方面,使用“android-support-v7-appcompat”

 in Properties -> Android add the library, but uncheck "IsLibrary”. -In Android -> Project build target check Android 4.0. -In "Java Build Path" -> Order and Export -> Unchecked the .jar library -Finally do a “Project -> Clean” both projects 

根据最新的(2014/5/19) 文件 ,第二步是:

在对话框左侧的类别面板中,selectAndroid。

然后,您将看到对话框右侧的库窗格。

尝试这个

  1. 打开SDKpipe理器
  2. 安装Android支持仓库
  3. 转到F: – \ Android设置\ android-sdk-21版本\ extras \ android \ support \ v7 \ appcompat \ libs
  4. 复制android-support-v7-appcompat.jar
  5. 将这个.jar粘贴到你的Project Lib文件夹中

设置和更改AndroidManifest.xml

  <uses-sdk android:minSdkVersion="9" android:targetSdkVersion="23" />