为什么我无法安装适用于Android库的Google Cloud Messaging

我正在按照有关在此处使用gcm的说明http://developer.android.com/guide/google/gcm/gs.html ,而且我被困在以下步骤:

安装帮助程序库要执行以下各节中描述的步骤,您必须首先安装帮助程序库(参考:客户机和服务器)。 从SDKpipe理器中, 安装附加function> Google消息传递Android库 。 这将在YOUR_SDK_ROOT / extras / google /下创build一个包含以下子目录的gcm目录:gcm-client,gcm-demo-appengine,gcm-demo-client,gcm-demo-server和gcm-server。

在我的SDKpipe理器中,我无法find选项:Google Cloud Messaging for Android Library,正如我在截图中捕获的那样 在这里输入图像说明 ,我该怎么办才能解决这个问题? 谢谢

Related of "为什么我无法安装适用于Android库的Google Cloud Messaging"

我有同样的问题。 在GCM显示之前,您必须在Eclipse插件中更新其他所有的东西。 强制从sdkpipe理器进行更新,一旦版本是最新的,它就会显示出来。

使用Android SDK Manager将您的SDK更新到r20,之后您还需要更新Eclipse插件。 然后,您可以在SDKpipe理器的Extras下findGoogle Cloud Messaging for Android Library以及其他所有内容。 只要select你想要安装。

如果出现以下错误: – android sdk manager没有安装

然后

  1. 转到android-sdk所在的文件夹。
  2. 右键单击SDKpipe理器,然后select以pipe理员身份运行。
  3. 重新开启eclipse。
  1. 运行Eclipse
  2. 去Eclipse菜单::帮助>>安装新软件
  3. 在这样的安装窗口设置如果你select“工作”列表框ADT网站::我的情况是这样的“ADT网站 – https://dl-ssl.google.com/android/eclipse ”全选

    • 开发工具
    • NDK插件和下一步完成…
  4. 现在转到“Android SDK Manager”窗口您将在“Extras”类别和“Google Cloud Messaging for Android Library”