通话需要API等级11(当前最小为1)

我刚刚删除了支持库(我将只支持一个API级别15的设备),并且在清理完项目后,我的代码运行良好。 但是,当我只触摸我使用getFragmentManager()的文件时,我得到这个Lint错误。

奇怪的是,我的清单中有minSdkVersion设置为15:

 <uses-sdk android:minSdkVersion="15" android:targetSdkVersion="18" /> 

我search了这个错误,但它所说的基本上是清理皮棉标记或清理项目。 哪个工作,但只有一次。

更新它更糟糕。 如果我不清理,但只是重新保存文件,错误加起来。 我从6个错误开始,现在有24个….

Solutions Collecting From Web of "通话需要API等级11(当前最小为1)"

我面临同样的问题。 我多次清理和构build这个项目,但一次又一次地得到这个问题。 我清理和build立项目,然后重新启动日食。 现在对我来说工作正常。

这是一个相同的问题,我发现这个答案是一个很好的解决scheme

不知道究竟是什么原因,但我通过从头开始重新创build项目,再次从SVN中重新检出来修复它。 (我不得不因为我有一台新的笔记本电脑)。

在我Team -> Share Project在elipse中Team -> Share Project之后,这种情况也是如此。

我从/libs添加了android-support-*.jar库到构buildpath,这解决了我的问题。