错误:安装APK时parsing软件包

我试图通过从雅虎电子邮件附件运行包安装程序来安装我的应用程序。 我的手机版本是4.1(Jellybean),所以这应该工作,对不对?

不过,我得到一个错误,说有一个parsing包的问题,​​尽pipe我的AndroidManifest指定minSdkVersion为1,而我的手机更高。

我已经启用安装来自不是从我的手机上的PlayStore来源的apk 。 我错过了什么?

Solutions Collecting From Web of "错误:安装APK时parsing软件包"

我得到一个错误,说parsing软件包时出现问题。

这是因为您的应用与您的设备不兼容。 它可能会让您的开发人员将minSDKVersion值设置为较高,如果您的设备API级别低于minSDKVersion则会提供parsing包错误,或者您的开发人员将maxSDKVersion设置为低于您的设备API级别。

例如:如果你的设备是Android 2.2,那么你的开发人员将APK设置为minSDKVersion为10,那么它不会在Android 2.2中工作,并将parsing软件包错误或如果你的开发人员设置maxSDKVersion为8,那么应用程序将不安装以上Android OS 2.2,如果你尝试安装,那么你会得到分析包错误。