依赖关系 – >无法创build“AppPlugin”types的插件

我试图继续在我的一个较老的项目上工作,这是大约一年前,并在当时工作很好,但现在我已经更新了AndroidStudio,它甚至不能build立了。

我得到一个错误,说我有两个相同的dex文件:

com.android.dex.DexException: Multiple dex files define Landroid/support/v4/accessibilityservice/AccessibilityServiceInfoCompat$AccessibilityServiceInfoVersionImpl; 

为了解决这个问题,我可以简单地使用“gradle dependencies”来查找罪魁祸首,并排除错误的文件,但这是我遇到的实际问题。
当我做'gradle依赖关系',我得到以下错误:

 FAILURE: Build failed with an exception. * Where: Build file 'F:\Github\Coinbook\app\build.gradle' line: 1 * What went wrong: A problem occurred evaluating project ':app'. > Could not create plugin of type 'AppPlugin'. * Try: Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. 

这里是我的完整build.gradle文件:

 apply plugin: 'com.android.application' android { compileSdkVersion 21 buildToolsVersion "21.1.2" defaultConfig { applicationId "com.moonrain.coinbook" minSdkVersion 14 targetSdkVersion 21 versionCode 1 versionName "0.7" } buildTypes { release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } } dependencies { compile project(':libs:AndroidBootstrap') compile files('libs/socialauth-4.4.jar') compile files('libs/socialauth-android-3.2.jar') compile 'com.doomonafireball.betterpickers:library:1.5.2' compile 'com.jakewharton:butterknife:6.0.0' compile 'com.astuetz:pagerslidingtabstrip:1.0.1' compile 'com.github.castorflex.smoothprogressbar:library:1.0.0' compile 'com.squareup.picasso:picasso:2.3.4' compile 'com.readystatesoftware.systembartint:systembartint:1.0.4' compile 'com.google.code.gson:gson:2.3' } 

所以这是我现在基本上坚持,我已经尝试了以下解决这个问题:
– 更新了AndroidStudio
– 更新了所有与SDK相关的项目
– 更新gradle
– 重新创build整个项目在一个新的文件夹,然后复制到我的文件到新的项目

每篇文章我发现有关这个问题,它说使用Gradle 0.7.3而不是0.7.2由于一个错误..但是,这就像一个岁,不再有效。

Solutions Collecting From Web of "依赖关系 – >无法创build“AppPlugin”types的插件"