cardCornerRadius显示错误

我正在学习Android的材料devise,但在它之间,它不断给错误。 谁可以帮我这个事?

工作区/ RecyclerCardView / res / layout / list_item_row.xml:2:错误:找不到包'com.Zybo.recyclercardview'中属性'cardCornerRadius'的资源标识符

<android.support.v7.widget.CardView xmlns:android="http://schemas.android.com/apk/res/android" xmlns:card_view="http://schemas.android.com/apk/res-auto" android:layout_width="match_parent" android:layout_height="match_parent" android:layout_margin="5dp" card_view:cardCornerRadius="5dp" > <LinearLayout android:layout_width="match_parent" android:layout_height="match_parent" android:orientation="vertical" > <ImageView android:id="@+id/img_id" android:layout_width="wrap_content" android:layout_height="wrap_content" android:layout_margin="7dp" /> <TextView android:id="@+id/txt_id" android:layout_width="wrap_content" android:layout_height="wrap_content" android:text="Hellooo..." /> </LinearLayout> </android.support.v7.widget.CardView> 

  • Android Studio中的“构build”中检测到哪些错误 - Gradle的angular色
  • 错误:在'android'包中找不到属性'textAlignment'的资源标识符
  • Mapbox在片段上膨胀视图
  • 如何使RatingBar显示五颗星
  • Android:使用XML自定义EditText布局
  • Android:在RecyclerView中的项目之间添加分隔符
  • TabLayout而不使用ViewPager
  • 如何根据Android Studio中的屏幕大小调整button大小
  •  compile 'com.android.support:cardview-v7:24.2.1' compile 'com.android.support:appcompat-v7:24.2.1' compile 'com.android.support:design:24.2.1' 

    以上就足够了。

    这对我有效

     app:cardCornerRadius="5dp" app:cardElevation="2dp" 

    感谢所有试图解决这个问题。 最后我得到了我的问题的答案:

    1. 分别从sdk/extras/v7/cardview导入卡片视图和回收视图
    2. sdk/extras/v7/recycleview
    3. 右键点击导入的项目去属性,并检查库框。
    4. 现在转到您正在工作的主项目,右键单击项目,添加这两个库转到属性 – > android(左侧) – >单击添加(库)(右下angular)和所需的库。

    用这个

     <android.support.v7.widget.CardView xmlns:android="http://schemas.android.com/apk/res/android" xmlns:tools="http://schemas.android.com/tools" xmlns:app="http://schemas.android.com/apk/res-auto" android:layout_width="match_parent" android:layout_height="wrap_content" app:cardCornerRadius="10dp" > 

    将这些依赖项添加到build.gradle。
    使用关键字实现而不是编译,因为它已被弃用

    实现'com.android.support:cardview-v7:26.1.0'
    实现'com.android.support:appcompat-v7:26.1.0'

    然后使用
    应用程式:cardCornerRadius = “5DP”

    代替
    card_view:cardCornerRadius = “5DP”