导入com.google.android.gms无法parsing

我是Android开发新手。 通过以下教程,我得到错误当我将代码写入MainActivity.java时, The import com.google.android.gms cannot be resolved

 import com.google.android.gms.maps.CameraUpdateFactory; import com.google.android.gms.maps.GoogleMap; import com.google.android.gms.maps.MapFragment; import com.google.android.gms.maps.model.BitmapDescriptorFactory; import com.google.android.gms.maps.model.LatLng; import com.google.android.gms.maps.model.Marker; import com.google.android.gms.maps.model.MarkerOptions; 

通过search各种修复程序,我一定要试试这些:

  • 我已经通过Android SDKpipe理器为特定的API级别下载了Google API。
  • 我将Google API作为项目构build目标进行了检查。
  • 我已经将<uses-library android:name="com.google.android.maps" />行作为<application>标记的子项添加到AndroidManifest.xml中。
  • 我通过selectProject->Clean...来清理项目,并从头构build它。
  • 我通过右键单击我的项目,包括地图的.jar文件,去build立path,并添加外部存档,find它在我的SDK中: android-sdk-windows\add-ons\addon_google_apis_google_inc_8\libs\maps

不幸的是,上述都没有帮助。

Solutions Collecting From Web of "导入com.google.android.gms无法parsing"

我将Google API作为项目构build目标进行了检查。

这与Maps V1无关,您正尝试使用Maps V2。

我通过右键单击我的项目,包括地图的.jar文件,去build立path,并添加外部存档,find它在我的SDK中:android-sdk-windows \ add-ons \ addon_google_apis_google_inc_8 \ libs \ maps

这是错误的。

首先, 切勿在Android项目中手动修改构buildpath 。 如果你这样做,充其量,你将在运行时崩溃,因为你认为你把你的项目(通过手动构buildpath变化)的JAR不在你的APK。 对于一个普通的第三方JAR,把它放在项目的libs/目录下,它会自动添加到你的构buildpath并将其内容添加到你的APK文件。

但是,Maps V2不是JAR。 这是一个包含JAR的Android库项目。 你需要整个图书馆项目。

您需要将android-sdk-windows\add-ons\addon_google_apis_google_inc_8项目导入到Eclipse中,然后将其作为对Android库项目的引用添加到您的应用程序中 。

另一种方法是让Eclipse为你做导入工作。 将鼠标hover在无法parsing的com.google.android.gms导入上,并在popup菜单的底部,selectFix project setup …选项,如下所示。 然后它会提示导入谷歌播放服务库。 select那个,你应该很好去。

在这里输入图像说明

从我的经验(Eclipse)中:

  1. 增加了google-play-services_lib作为一个项目,并从我的应用程序引用它。
  2. 删除手动添加的所有jar子
  3. 在我的项目的“libs”文件夹中添加了google-play-services.jar。
  4. 我有一些很大的问题,因为我搞乱了订单和导出选项卡,所以工作解决scheme(按此顺序):src,gen,Google API,Android依赖项,Android专用库(只有这个检查被导出)。

在我的情况下还是全部使用android studio

你可以导入谷歌播放服务

放在你的build.gradle

 compile 'com.google.android.gms:play-services:7.8.0' 

或最新版本的播放服务取决于你看这个答案的时间

更具体的import

请查看这个个人gradleimport

https://developers.google.com/android/guides/setup

谷歌地图

 com.google.android.gms:play-services-maps:7.8.0 

可能发生错误

如果在使用Gradle文件同步项目时遇到错误

在这里输入图像说明

确保你安装最新的更新

1- Android支持信息库。

2- Android支持库。

3- Google Repository。

4-Google Play服务。

在这里输入图像说明

你可能需要重新启动你的android studio来响应

请注意,一旦将google-play-services_lib项目导入到IDE中,您还需要将google-play-services.jar添加到:Project => Properties => Java build path => Libraries =>添加JAR

以上解决scheme应该能解决你的问 如果没有,请确保使用SDKpipe理器更新您的Android sdk并安装最新的lib项目,然后重复上述步骤。

再一次确保这两件事情正确地发生,没有比这更多。 (对于ECLIPSE用户)

1)从 – > C:\ Users(您的用户名)\ android-sdks \ extras \ google \ google_play_services \ libproject \ google-play-services_lib \ libs \ google-play-services.jar复制jar文件

2)右键点击Project – > Build Path – > Add External Archive-> google-play-services.jar

在Android Studio转到:文件 – >项目结构… – >通知(最后一项) – >检查谷歌云消息

等待几秒钟,你就完成了:) import com.google.android.gms.gcm.GcmListenerService应该正确解决

我也有同样的问题。 通过编译最新的sdk工具版本得到解决(播放服务,构build工具等)。 示例build.gradle如下所示,以供参考。

  apply plugin: 'com.android.application' android { compileSdkVersion 23 buildToolsVersion "23.0.1" defaultConfig { applicationId "com.abc.bcd" minSdkVersion 14 targetSdkVersion 23 versionCode 1 versionName "1.0" } buildTypes { release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } } dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) compile 'com.google.android.gms:play-services:8.4.0' compile 'com.android.support:appcompat-v7:23.0.1' } 

假设您正在使用ECLIPSE:

右键单击PROJECT PROPERTIES ANDROID

如果您检查了ANDROID版本,则必须将其更改为GOOGLE API。 select与您的项目目标版本兼容的GOOGLE APIS版本。

在我的情况下,只有当我添加gcm.jar到lib文件夹,它开始工作。 它在这里: C:\adt-bundle-windows-x86_64-20131030\sdk\extras\google\gcm\gcm-client\dist

所以google-play-services.jar没有工作…

我有同样的问题,所以愚蠢的API我决定如下更改导入行

 import com.google.android.gms.maps.model.LatLng;