未能解决:com.google.firebase:firebase-database:10.2.0

我正在创build一个新项目,并尝试从谷歌实现一些functionFire base依赖项,如编译com.google.firebase:firebase-database:10.2.0,classpath“com.google.gms:google-services:3.0.0 ''并与他们同步我的项目。 当试图这样做,我得到这个错误:

Error:(25, 13) Failed to resolve: com.google.firebase:firebase-database:10.2.0 <a href="openFile:M:/Downloads/CommunicationApp/app/build.gradle">Show in File</a><br><a href="open.dependency.in.project.structure">Show in Project Structure dialog</a> 

也是这个错误:

 Error:Failed to resolve: com.google.firebase:firebase-core:10.2.0 <a href="openFile:M:/Downloads/CommunicationApp/app/build.gradle">Open File</a><br><a href="open.dependency.in.project.structure">Show in Project Structure dialog</a> 

如果有人知道我的解决scheme,非常感谢!

Solutions Collecting From Web of "未能解决:com.google.firebase:firebase-database:10.2.0"

当我尝试使用firebase-messaging:10.2.0并解决这个问题时,我遇到了同样的问题:

  • 在Android Studio上,进入菜单栏并点击工具> Android> SDKpipe理器。
  • 点击SDK Tools标签
  • 请检查Google Play服务框以及Google存储库框。
  • 点击应用,它会在应用新的更新之前提示你。
  • 点击确定,然后等待下载
  • 再次同步您的项目,一切都很好。

注意:所有com.google.android.gms库必须使用完全相同的版本规范(混合版本可能导致运行时崩溃)。 如果你已经有一个现有的谷歌播放服务的依赖项升级到与firebase相同的版本。

 compile 'com.google.android.gms:play-services:10.2.0' compile 'com.google.firebase:firebase-database:10.2.0' 

希望有所帮助!

尝试在Android SDK Manager中更新Google Repository,然后重新同步Gradle