没有可用于此目标的cpu / abi系统映像

尝试创build虚拟设备时,出现此错误(我是全新的android开发,遵循教程来设置所有内容)。

我发现的所有东西都只是说为你使用的目标安装ARM或Intel系统映像。

为了以防万一,我为Android 4.4W(API20)和Android L(API 20,L Preview)安装了这两个。 我也试过每个安装的系统映像只有一个,如果它们以某种方式可能会相互干扰,但是这不起作用。

SDK管理器

AVD

如果有人有任何想法我错过了什么,那将是伟大的!

谢谢

  • 在Nexus上将Android升级到4.2.2后,Eclipse显示目标未知的设备?
  • 当从windows和mac构建时,为什么android apk大小不同
  • Android VM在启动Mac上崩溃
  • 在正确的path下找不到aapt
  • R.raw.anything无法解决
  • Android SDK需要Android开发人员工具包版本17.0.0或更高版本
  • 从Eclipse切换到适用于Android开发的IntelliJ IDEA的好处
  • Android Geocoder getFromLocationName始终返回null
  • 该SDK只是愚蠢的,删除图像,并重新安装。

    正如詹姆斯 在这里所说:

    只是因为CPU / ABI说“没有为这个目标安装系统映像”。 您需要安装系统映像。

    在Android SDK Manager中,检查您是否安装了“ARM EABI v7a系统映像”(对于4.0以上的每个Android版本,您必须安装系统映像才能运行虚拟设备)