Eclipse ADT更新不起作用

更新了我的android sdk,并试图通过ecplise更新我的adt

帮助 – >检查更新

这个动作导致了这样一个对话框:

找不到更新

但是我的SDK说:

这个android是SDK需要Android开发工具包21.1.0或以上当前版本是21.1.0.v201212060256-543035

请更新ADT到最新版本。

帮助我,你有我的巨大的不朽的感激之情。

Solutions Collecting From Web of "Eclipse ADT更新不起作用"

编辑。 26/03/2016

请注意, Google宣布:Eclipse中对Android开发者工具(ADT)的支持已经结束 ,因此请考虑迁移到Android Studio。


解:

我发现最快的安装方式解决了这个问题, 而不删除Eclipse,或丢失任何数据/设置

  1. 这里下载最新版本的ADT,目前ADT-23.0.7.zip (*)
  2. Eclipse > Help > Install new software... >取消选中Contact all update sites during install to find required software (底部,最后一个首选项),以避免在安装过程中出现任何不必要的延迟。
  3. 相同的屏幕(顶部)单击Add > Archive >select下载的ADT-XXXzip >按照屏幕上的安装步骤

正如用户在评论中提到的,如果您仍然面临更新问题,您可能会尝试在安装之前删除以前版本的ADT。


(*) 之前的版本:

  • ADT-23.0.0.zip | ADT-23.0.2.zip | ADT-23.0.3.zip | ADT-23.0.4.zip | ADT-23.0.6.zip
  • ADT-22.6.0.zip | ADT-22.6.1.zip | ADT-22.6.2.zip | ADT-22.6.3.zip
  • ADT-22.3.0.zip
  • ADT-22.2.1.zip
  • ADT-22.0.0.zip | ADT-22.0.1.zip | ADT-22.0.5.zip
  • ADT-21.1.0.zip

编辑,以适应ADT的更新,这个解决scheme似乎在任何版本的工作 :D

我有同样的问题。 由于某种原因,命令行更新不适用于我。 这是我之前没有经历过任何更新的某种错误。 以下是我所做的修复:

  • 我删除了我的eclipse安装

  • 从开发者网站下载了一份新的SDK

  • 解压SDK,只复制eclipse文件夹

  • 用这个replace了我的旧的eclipse文件夹(删除了其余的下载,因为我已经有了sdk)

  • 启动了eclipse,并将工作空间位置指向我已有的旧工作空间。 我所有的项目都离开了他们。

也可能有其他的方法。 这个对我来说似乎最简单。 其他人则build议逐个更新每个eclipse组件,但是这对我来说太乏味了。 如果你的eclipse安装过多地被定制,并且你安装了很多的插件,那么find一个替代scheme可能是有意义的。 我的安装总是非常简约,所以我不介意把它扔掉,从头开始。

希望这可以帮助!

我有另一个ADT 23 +的问题。

我的ADT插件已经过时了,但是Eclipse仍然在说已经安装了最新的版本。 用存档手动安装最新的ADT版本也不起作用。

Eclipse是错误的,所以我做了一个干净安装的ADT插件。

  1. 在Eclipse中卸载ADT: 帮助>关于Eclipse>安装详细信息

  2. select插件,然后点击卸载…

  3. 重新启动Eclipse

  4. 再次安装ADT: 帮助>安装新软件…

升级到22.6.1时我也有类似的问题,我得到了Android团队的支持。 解决scheme非常简单。

你需要去帮助 – 安装新的软件,并selecthttpS ://( s是重要的)更新站点,然后执行安装。

在Android问题跟踪器上查看此解决scheme 。

并在链接http://developer.android.com/sdk/installing/installing-adt.html#Troubleshooting在谷歌Android开发的页面

他们说:

如果Eclipse无法find包含ADT插件的远程更新站点,请尝试将远程站点URL更改为使用http而不是https。 即,将远程站点的位置设置为:

 http://dl-ssl.google.com/android/eclipse/ 

对我来说 – 这是帮助。

如果madlymad的解决scheme不工作,你也可以尝试这个解决scheme已经为我工作。

简而言之:完全卸载adt,然后使用归档再次安装(如上所示)。

没有卸载,我遇到了冲突的jar子。

在此下载更新的软件包:

win32: 在这里

不幸的是,你将无法更新现有的安装。 只需使用Eclipse的新副本并使用更新站点安装插件,或使用该包。

或者,您可以通过删除所有旧的Android插件来解决此问题。 一旦你删除了所有旧的Android插件,你可以安装新的。

  1. 打开Eclipse
  2. select帮助
  3. select关于Eclipse SDK
  4. select安装细节
  5. 高亮所有Android插件
  6. select卸载
  7. 重新启动Eclipse
  8. 然后像平常一样重新安装插件
  9. 重新启动Eclipse

在这一点上一切都应该再次工作。

解决方法: https : //code.google.com/p/android/issues/detail?id = 73102

您可以随时尝试更新Eclipse之外的SDK工具和平台工具。

在CMD或terminaltypes中:

  $ android 

SDKpipe理器将启动。