在eclipse中更新ADT 23.0.0时出错

我已经经历了这个问题,但没有帮助。 使用Android开发工具更新eclipse 23

在启动eclipse时显示下面的错误。

在这里输入图像说明

当我尝试检查更新 – 它什么都不做。

然后我试了一下

帮助 – >安装新软件 – >“ https://dl-ssl.google.com/android/eclipse/ ”

它显示下面的错误

Cannot complete the install because of a conflicting dependency. Software being installed: Android Native Development Tools 23.0.1.1256982 (com.android.ide.eclipse.ndk.feature.feature.group 23.0.1.1256982) Software currently installed: Android Native Development Tools 22.6.3.v201404151837-1123206 (com.android.ide.eclipse.ndk.feature.group 22.6.3.v201404151837-1123206) Only one of the following can be installed at once: ADT CDT Integration 23.0.1.1256982 (com.android.ide.eclipse.ndk 23.0.1.1256982) ADT CDT Integration 22.6.3.v201404151837-1123206 (com.android.ide.eclipse.ndk 22.6.3.v201404151837-1123206) Cannot satisfy dependency: From: Android Native Development Tools 23.0.1.1256982 (com.android.ide.eclipse.ndk.feature.feature.group 23.0.1.1256982) To: com.android.ide.eclipse.ndk [23.0.1.1256982] Cannot satisfy dependency: From: Android Native Development Tools 22.6.3.v201404151837-1123206 (com.android.ide.eclipse.ndk.feature.group 22.6.3.v201404151837-1123206) To: com.android.ide.eclipse.ndk [22.6.3.v201404151837-1123206] 

任何人都可以帮我这个。 谢谢。

Solutions Collecting From Web of "在eclipse中更新ADT 23.0.0时出错"

解决!

去帮助 – 关于Eclipse卸载DDMS,ADT等去安装新的软件,并使用链接安装它们: – https://dl-ssl.google.com/android/eclipse/

为我工作:)

回滚到adt22.6.2,只需要replaceandroid sdk中的工具文件夹即可。

这是一个包装错误。 整个proguard文件丢失。 我们将尽快更新,但在此之前只需从以前版本的工具中复制即可:

http://dl.google.com/android/android-sdk_r22.6.2-windows.zip

http://dl.google.com/android/android-sdk_r22.6.2-macosx.zip

所以最后如果你从一个新的ADT副本手工开始的文件:)

我也面临同样的问题,因为没有任何工作对我来说,我只是用早期版本(我最初安装)replace整个ADT基本文件夹,所以现在重新开始

我面临同样的问题,能够以这种方式解决 –

  1. Eclipse – >帮助 – >关于Eclipse —->安装细节
  2. select – Android DDMS,ADT,Android Hierarchy Viewer,Android Native开发工具,Android TraceView和Tracer for OpenGL ES软件包。 所有版本必须是22.xx版本
  3. 卸载上面select的所有插件。
  4. 重新启动Eclipse
  5. 从更新站点安装ADT – https://dl-ssl.google.com/android/eclipse/

因为上面的解决scheme都没有为我工作( 只是replace的解决scheme除外

我刚刚去了

sdk \ tools \ lib \ monitor-x86(32bit)

复制configuration,function和插件文件夹,并将其粘贴在ADT \ eclipse文件夹中select跳过它要求更换和rest将罚款,无需更换整个事情

DONE

一旦你开始eclipse它会问你的SDK位置,提供的位置,并继续

我昨天也遇到了类似的问题,我试了上面的解决scheme,但是仍然不能正常工作。 我正面临一些错误和困难。

所以我重新安装了Eclipse Luna,然后执行以下操作:

下载并安装插件,然后使用SDK Manager更新API。 现在我推荐使用Android Studio