Eclipse尝试启动Android应用程序时卡住了

我试图在Motorola Milestone A853上运行helloandroid应用程序。 我input“adb设备”,移动设备被正确识别。 但是,当我尝试运行应用程序时,Eclipse总是停留在27%“启动代理”。

这可能是原因?

Solutions Collecting From Web of "Eclipse尝试启动Android应用程序时卡住了"

有一个模拟器相同的27%的问题。 在我删除AVD并重新创build之后,它才被修复,所以很可能与设备/仿真器相关(并且重启ADB并不能解决问题)。

编辑:

在项目页面发现了问题#21073,由benpar回答:

更新:如果从Eclipse中的AVDpipe理器启动AVD仿真器,也可以避免这种情况。 从Eclipse的“运行”button启动第一个模拟器时会发生该问题。

避免:

  1. 启动Eclipse
  2. 窗口 – > AVDpipe理器
  3. 启动一个模拟器
  4. 运行该项目

在模拟器中运行应用程序时,我也遇到了这个问题。 确保模拟器运行之前,启动应用程序,你不会有这个问题。

要获得更多信息,请尝试从Eclipse以外的命令行安装并启动应用程序。 您可以在项目的/ bin文件夹中find.apk,然后使用:

adb install -r <projectname>.apk 

它可能工作,如果没有,你可能会得到有关错误原因的更好的信息。 我对Eclipse的使用经验表明,它可能会挑剔,这应该可以帮助你隔离这个问题。

我有同样的困难在27%的问题。 拔掉设备插头并将其固定。

我发现最快的方法是在命令行上用Android Debug Bridge进行检查。 有时候只需要停止并启动adb服务器。 那是:

adb kill-server

将停止服务器。 然后:

adb start-server

这应该做到这一点。 检查连接的设备(但没有必要)

adb devices

并列出所连接的设备。
然后回到eclipse并再次开始debugging。

这也可以通过Eclipse在Devices视图中完成。

我得到了这个问题的解决scheme有点傻。 我所做的是从Eclipse的一个实例开始模拟器。闭日食。 closureseclipse不会停止模拟器。 现在重新启动eclipse。 现在在已经运行的模拟器中运行你的应用程序。

非常烦人的问题。 我不得不closures日食和模拟器,然后再次启动,这是非常耗时的。 来到这里,阅读安娜李尔和维纳发布的内容。 成功了! 我认为在我的情况下,这个问题发生,因为我模拟器仍在运行时退出eclipse。 正如Anna和Vinay所写的那样,要纠正这个问题…

确保eclipse和模拟器closures,然后…

  1. 启动elipse
  2. 启动模拟器
  3. 退出eclipse(不要退出模拟器)
  4. 开始日食
  5. 现在运行你的程序(应该加载100%,而不是卡住)

对我来说是挂了的亚行。 无论是日食还是模拟器都没有任何影响。

  1. 终止模拟器
  2. 终止亚行,(我只是用任务pipe理器杀死了它的进程。
  3. 再次启动仿真器(也会导致ADB重新启动)
  4. 运行你的程序

它不应该卡住。

我正在使用三星Galaxy来运行应用程序。 我浪费了很多时间在运行应用程序,但它不是启动,我不得不每次重新启动eclipse。 对我来说,我只是按照这些步骤,没有任何问题了

  • 从我的电脑中取出我的设备
  • 运行应用程序
  • 当它要求连接你的设备或创buildAVD。
  • 我重新连接我的设备,并select输出。
  • 最后我解决了这个问题