Eclipse没有创build新的Activity和xml布局文件(在更新eclipse和sdk后开始的问题)

今天我已经更新了Android SDK工具和eclipse。 目前的SDK工具24.0.1,Android开发工具23.0.4.1468518,eclipse版本4.4.1。 更新SDK和Eclipse后,我创build了新的项目。 在这个项目中src文件夹是空的&res / layout文件夹也是空的,activity&xml文件没有创build。 我必须手动创build它。

我看到了我的答案,如链接1 , 链接2等

回答如下:“试试这个”帮助“ – >”安装新软件“并从这个URL安装(这将更新它): https : //dl-ssl.google.com/android/eclipse/ ”

但是我已经更新了,但是没有解决我的问题。 那么,如何自动创buildactivity&xml?

Solutions Collecting From Web of "Eclipse没有创build新的Activity和xml布局文件(在更新eclipse和sdk后开始的问题)"

最新

正如我已经说过, ADT 23.0.4SDK 24.0.1彼此不兼容。

我们已经把Android SDK另一个版本更新到了24.0.2 (可能是他们的团队阅读了我们的这个问题,并且很快发布了一个更新)。 然而这个更新在这个页面上还没有被logging下来,但是你仍然可以在Eclipse's SDK Manager看到它。

我更新了我的SDK到24.0.2 ,现在它工作正常。 你也可以尝试更新你的Android SDK24.0.2 ,希望一切都会正常工作。

较老的答案

ADT Plugin for EclipseAndroid SDKADT Plugin for Eclipse应该相互兼容,以便Eclipse自动执行此类操作。

但似乎ADT 23.0.4 (Released in October 2014)SDK Tools, Revision 24.0.1 (Released in December 2014)不兼容。

我们应该期待更新ADT插件,它将与SDK工具24.0.1兼容。

你可以从文档中检查:

对于SDK Tools,Revision 23.0.4(2014年10月),他们提到了以下几点。

Android SDK平台工具修订版19或更高版本。

如果您使用ADT在Eclipse中进行开发,请注意,此版本的SDK Tools专为ADT 23.0.4和更高版本而devise。

如果你注意到,

但是对于SDK Tools,Revision 24.0.0&24.0.1(2014年12月),他们只提到了

Android SDK平台工具修订版19或更高版本。

如果你检查这个文件,那么你会发现SDK 23或更早的版本,每个版本都提到兼容的ADT版本,但是只有24版本,他们还没有提到任何东西。 所以兼容版本还没有来。

我有同样的问题,但最终不得不撤消我的更新到SDK工具回到23.0.4。

如果你想取消你的更新,你可以按照以下简单的步骤:

  1. 手动下载旧的ADT插件。
  2. 提取内容并从那里复制tools文件夹。
  3. 转到您的SDK installation directory并replacetools文件夹。

你的SDK将回到23版本,一切都将重新开始工作。

尝试再次运行Android SDK Manager,为Tools类别安装任何可用更新,然后从Eclipse菜单中selectHelp > Check for Updates (在此处安装任何检测到的更新,然后重新启动Eclipse)。

我之前遇到同样的问题,在上述过程之后安装了Android SDK Tools版本24.0.2后,它又开始工作了。

试试这个:当创build一个新的android应用程序使用“空白活动”,而不是“空白活动”。

这将立即解决问题。

有时你必须在崩溃之后重新安装eclipse。 这就是为什么这是一个好主意,他们使它变得便携。 但是你可以试着从eclipse卸载组件回来。 但根据我的经验,如果你吹了ini,所有这些可能最快的方法就是重新安装,尤其是当adt中有这么多的依赖时。

你也可以安装常规的eclipse和android插件,你不必只使用adt。 也许日食更像这样稳定

另一件事你可能需要重新编译项目