在我现有的项目(eclipse)中导入CardView和RecyclerView(Android 5.0)

我想在我现有的项目中导入CardView和RecyclerView。 我正在使用ECLIPSE。 我阅读其他答案在stackoverflow,但他们都是Android Studio。 ve谁能帮我吗?

我收到的错误是:CardView无法parsing为一个types。

更新:Commonwares的答案帮助我解决了这个问题。 但是现在我又有了一个错误。 (错误膨胀类和android.support.v7.widget.CardView)。 请有人帮助我。

Solutions Collecting From Web of "在我现有的项目(eclipse)中导入CardView和RecyclerView(Android 5.0)"

它们也可以在Android库项目中使用,在SDK安装的extras/android/support/v7/中。 在硬盘上的其他地方复制这些项目,将它们导入到Eclipse中,然后按照文档中的说明将它们作为来自应用程序的库引用。

目前要获得recyclerView,你首先从sdkpipe理器下载“Extras”部分的Android支持库,然后你需要从这里导入所有库(从你的sdk文件夹path开始):

 sdk\extras\android\m2repository\com\android\support 

在这里输入图像说明

添加android-support-v7-recyclerview.jar文件夹: sdk\extras\android\support\v7\recyclerview\libslibs解决了我的问题。

对于RecyclerView,我能够通过简单地添加回收站的libs文件夹中获得的回收站jar文件在cardview的v7支持文件夹中运行,我作为一个android项目导入它,作为一个库,并添加到我的项目。 在我的安卓用户界面工作完美的第一次运行,但现在它显示UI编辑器中的错误,但在模拟器中完美运行。 希望能帮助到你

最后,我解决了我的问题。

… / SDK /演员/安卓/支持/ V7 /

 >appcompat >libs >android-support-v4.jar >android-support-v7-appcompat.jar >cardview >libs >android-support-v7-cardview.jar >gridlayout >libs >android-support-v7-gridlayout.jar >mediarouter >libs >android-support-v7-mediarouter.jar >palette >libs >android-support-v7-palette.jar >recyclerview >libs >android-support-v7-recyclerview.jar 

复制上面的所有jar文件到你的项目库,并使用这个android-support-v4.jar而不是你的

appcompat-v7.jar添加到您的库中。 这个问题将得到解决。