不能在eclipse中导入java.awt.geom

我刚开始研究一个新的Eclipse Android项目,并希望使用java.awt.geom包中的类。 我安装了OpenJVM 1.6和sun 1.6 jdk,都来自debian的仓库。 当我尝试导入包时,它说导入无法parsing(事实上,Eclipse的自动完成只显示awt和awt.font)。

当我看着在Eclipse中设置的JRE系统库时,我对此感到无比困惑: Window> Preferences> Java> Installed JREs> Edit .. 并且我看到包含了rt.jar ,当我在磁盘上find这个jar并用jar ft rt.jar检查它的内容时,我发现它包含了java / awt / geom类。

有谁知道我为什么不能在Eclipse中导入这个包?

谢谢

Solutions Collecting From Web of "不能在eclipse中导入java.awt.geom"

Android不严格使用JRE库。 其中一些是可用的,其中一些不是,这取决于Android SDK包含的内容。 Android项目是针对Android SDK构build的,它看起来没有这个库。

有关Android SDK包含的正式列表, 请转到源代码 :Google,然后签出您正在构build的特定Android版本的“参考”选项卡。

这造成一些混乱,我知道。 尽pipe大多数Android SDK使用了官方(或Open)JDK中的许多熟悉的东西,但它们在技术上并不相同。

另外, 为什么Android使用Java的答案之一? 解释说,Android的源代码是Java(在语言语法,结构等方面),但是当编译为字节码时, 它不使用JDK