Eclipse的错误,“select无法启动,并没有最近启动”

我刚刚开始Android编程,所以下载了Eclipse并开始使用。

创build我的第一个项目,从这里教程: http : //developer.android.com/training/basics/firstapp/creating-project.html#CommandLine

当我在下一课,从这里运行该应用程序: http : //developer.android.com/training/basics/firstapp/running-app.html

我照他们的话说。 通过USB连接我的设备,启用USBdebugging,但是当我点击在Eclipse上运行,得到了上述错误。

在这里输入图像说明

我做错了什么?

Solutions Collecting From Web of "Eclipse的错误,“select无法启动,并没有最近启动”"

Eclipse不能解决你想运行的问题,既然你之前没有运行任何东西,它也不能尝试重新运行。

点击绿色的“运行”button,点击旁边的下拉菜单,然后select运行configuration。 在Android选项卡上,确保将其设置为您的项目。 在“目标”选项卡中,根据需要设置checkbox和选项以定位设备。 然后点击运行。 请留意Eclipse中的“控制台”选项卡 – 这会让您知道发生了什么事情。 一旦你设置了运行configuration,你可以在下次点击绿色的“运行”button。

有时候,让所有的东西与你的设备交谈可能是有问题的。 考虑使用AVD(即模拟器)作为替代scheme,至less在有问题时开始使用。 您可以从Eclipse的菜单窗口 – > Android虚拟设备pipe理器轻松创build一个。

要查看您的设备上正在安装和启动的项目的进度,请检查控制台。 这是Eclipse中的一个面板,其中包含Problems / Javadoc / Declaration / Console / LogCat等选项卡。可以最小化 – 检查右下方的托盘。 或者使用菜单中的“窗口/显示视图/控制台”使其显示在最前面。 有两个控制台,Android和DDMS – 有一个下拉的图标,你可以切换。

按照以下步骤在连接的设备上运行您的应用程序。 1.将目录更改为Android项目的根目录并执行: ant debug 2.确保Android SDK platform-tools/目录包含在PATH环境variables中,然后执行: adb install bin/<*your app name*>-debug.apk在您的设备上,find<*your app name*>并将其打开。

请参阅运行App